summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/threadpool/threadpool-0.2.5.ebuild')
-rw-r--r--dev-cpp/threadpool/threadpool-0.2.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-cpp/threadpool/threadpool-0.2.5.ebuild b/dev-cpp/threadpool/threadpool-0.2.5.ebuild
new file mode 100644
index 000000000000..6b82416dade7
--- /dev/null
+++ b/dev-cpp/threadpool/threadpool-0.2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="A cross-platform C++ thread pool library (built on top of Boost)"
+HOMEPAGE="http://threadpool.sourceforge.net/"
+MY_PV=${PV//./_}
+MY_P=${PN}-${MY_PV}
+SRC_URI_BASE="mirror://sourceforge/threadpool/threadpool/${PV}%20%28Stable%29"
+SRC_URI="${SRC_URI_BASE}/${MY_P}-src.zip
+ doc? ( ${SRC_URI_BASE}/${MY_P}-doc.zip )"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="dev-libs/boost"
+
+S="${WORKDIR}/${MY_P}-src/${PN}"
+
+PATCHES=( "${FILESDIR}/${P}-memleak.patch" )
+
+src_prepare() {
+ base_src_prepare
+}
+
+src_compile() {
+ # Do nothing
+ # The makefile just builds the documentation again
+ # Not even any install targets
+ :
+}
+
+src_install() {
+ insinto /usr/include/
+ doins -r boost
+ dodoc README TODO CHANGE_LOG
+ if use doc; then
+ dohtml -r "${WORKDIR}"/"${MY_P}"-doc/
+ fi
+}