summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-9999.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-9999.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/dev-db/postgresql/postgresql-9999.ebuild b/dev-db/postgresql/postgresql-9999.ebuild
index 300a8efb7935..af236abbcc11 100644
--- a/dev-db/postgresql/postgresql-9999.ebuild
+++ b/dev-db/postgresql/postgresql-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit eutils flag-o-matic git-2 linux-info multilib pam prefix \
+inherit eutils flag-o-matic git-r3 linux-info multilib pam prefix \
python-single-r1 systemd user versionator
KEYWORDS=""
@@ -13,7 +13,7 @@ KEYWORDS=""
# Bump when rc released.
SLOT="11"
-EGIT_REPO_URI="git://git.postgresql.org/git/postgresql.git"
+EGIT_REPO_URI="https://git.postgresql.org/git/postgresql.git"
LICENSE="POSTGRESQL GPL-2"
DESCRIPTION="PostgreSQL RDBMS"
@@ -75,11 +75,6 @@ sys-devel/flex
nls? ( sys-devel/gettext )
xml? ( virtual/pkgconfig )
"
-src_unpack() {
- base_src_unpack
- git-2_src_unpack
-}
-
RDEPEND="${CDEPEND}
!dev-db/postgresql-docs:${SLOT}
!dev-db/postgresql-base:${SLOT}
@@ -124,7 +119,7 @@ src_prepare() {
die 'PGSQL_PAM_SERVICE rename failed.'
fi
- epatch_user
+ eapply_user
}
src_configure() {
@@ -188,8 +183,9 @@ src_install() {
if use systemd; then
sed -e "s|@SLOT@|${SLOT}|g" -e "s|@LIBDIR@|$(get_libdir)|g" \
- "${FILESDIR}/${PN}.service-9.6" | \
+ "${FILESDIR}/${PN}.service-9.6-r1" | \
systemd_newunit - ${PN}-${SLOT}.service
+ systemd_newtmpfilesd "${FILESDIR}"/${PN}.tmpfiles ${PN}-${SLOT}.conf
fi
newbin "${FILESDIR}"/${PN}-check-db-dir ${PN}-${SLOT}-check-db-dir
@@ -234,7 +230,7 @@ src_install() {
if use prefix ; then
keepdir /run/postgresql
- fperms 0775 /run/postgresql
+ fperms 1775 /run/postgresql
fi
}
@@ -273,6 +269,7 @@ pkg_preinst() {
}
pkg_postinst() {
+ use server && use systemd && systemd_tmpfiles_create ${PN}-${SLOT}.conf
postgresql-config update
elog "If you need a global psqlrc-file, you can place it in:"