summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/slony1/slony1-2.2.1.ebuild')
-rw-r--r--dev-db/slony1/slony1-2.2.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-db/slony1/slony1-2.2.1.ebuild b/dev-db/slony1/slony1-2.2.1.ebuild
deleted file mode 100644
index c4ecc5daa8ef..000000000000
--- a/dev-db/slony1/slony1-2.2.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils versionator
-
-IUSE="doc perl"
-
-DESCRIPTION="A replication system for the PostgreSQL Database Management System"
-HOMEPAGE="http://slony.info/"
-
-# ${P}-docs.tar.bz2 contains man pages as well as additional documentation
-MAJ_PV=$(get_version_component_range 1-2)
-SRC_URI="http://main.slony.info/downloads/${MAJ_PV}/source/${P}.tar.bz2
- http://main.slony.info/downloads/${MAJ_PV}/source/${P}-docs.tar.bz2"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-DEPEND="|| (
- dev-db/postgresql:9.3[server]
- dev-db/postgresql:9.2[server]
- dev-db/postgresql:9.1[server]
- dev-db/postgresql:9.0[server]
- )
- dev-db/postgresql[threads]
- perl? ( dev-perl/DBD-Pg )
-"
-
-pkg_setup() {
- local PGSLOT="$(postgresql-config show)"
- if [[ ${PGSLOT//.} < 83 ]] ; then
- eerror "You must build ${CATEGORY}/${PN} against PostgreSQL 8.3 or higher."
- eerror "Set an appropriate slot with postgresql-config."
- die "postgresql-config not set to 8.3 or higher."
- fi
-
-# if [[ ${PGSLOT//.} > 90 ]] ; then
-# ewarn "You are building ${CATEGORY}/${PN} against a version of PostgreSQL greater than 9.0."
-# ewarn "This is neither supported here nor upstream."
-# ewarn "Any bugs you encounter should be reported upstream."
-# fi
-}
-
-src_configure() {
- local myconf
- use perl && myconf='--with-perltools'
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc INSTALL README SAMPLE TODO UPGRADING share/slon.conf-sample
-
- if use doc ; then
- cd "${S}"/doc
- dohtml -r *
- fi
-
- newinitd "${FILESDIR}"/slony1.init slony1
- newconfd "${FILESDIR}"/slony1.conf slony1
-}