summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/Manifest1
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch35
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild63
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/metadata.xml5
-rw-r--r--dev-db/lib_mysqludf_json/Manifest1
-rw-r--r--dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild58
-rw-r--r--dev-db/lib_mysqludf_json/metadata.xml5
-rw-r--r--dev-db/lib_mysqludf_preg/Manifest1
-rw-r--r--dev-db/lib_mysqludf_preg/lib_mysqludf_preg-1.0.1.ebuild58
-rw-r--r--dev-db/lib_mysqludf_preg/metadata.xml5
-rw-r--r--dev-db/lib_mysqludf_stat/Manifest1
-rw-r--r--dev-db/lib_mysqludf_stat/files/lib_mysqludf_stat-warnings.patch20
-rw-r--r--dev-db/lib_mysqludf_stat/lib_mysqludf_stat-0.0.3.ebuild59
-rw-r--r--dev-db/lib_mysqludf_stat/metadata.xml5
-rw-r--r--dev-db/lib_mysqludf_str/Manifest1
-rw-r--r--dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild56
-rw-r--r--dev-db/lib_mysqludf_str/metadata.xml5
-rw-r--r--dev-db/lib_mysqludf_sys/Manifest1
-rw-r--r--dev-db/lib_mysqludf_sys/lib_mysqludf_sys-0.0.3.ebuild58
-rw-r--r--dev-db/lib_mysqludf_sys/metadata.xml5
-rw-r--r--dev-db/lib_mysqludf_ta/Manifest1
-rw-r--r--dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild67
-rw-r--r--dev-db/lib_mysqludf_ta/metadata.xml8
-rw-r--r--dev-db/lib_mysqludf_udf/Manifest1
-rw-r--r--dev-db/lib_mysqludf_udf/lib_mysqludf_udf-0.0.3.ebuild52
-rw-r--r--dev-db/lib_mysqludf_udf/metadata.xml5
26 files changed, 0 insertions, 577 deletions
diff --git a/dev-db/lib_mysqludf_fPROJ4/Manifest b/dev-db/lib_mysqludf_fPROJ4/Manifest
deleted file mode 100644
index d82a77b9f652..000000000000
--- a/dev-db/lib_mysqludf_fPROJ4/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lib_mysqludf_fPROJ4-0.1.0.tar.gz 2573 BLAKE2B 4b6863b2b643464b5f7229e5a74c5f220894916b496eed077efe8a58df43f61fe25c252db09dc41c7e2705692e3f3915883e1096b9826f11431c1fec59c467e6 SHA512 cc0307bcbdf15a37f77fced46b262783327fbd1e9883bd2d3f55c005bc5948ea7d2b7afa98a75390045636abbb04bb22aeaafdbe670e5642710a6a4a785fd3b3
diff --git a/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch b/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch
deleted file mode 100644
index 0b9669991cb3..000000000000
--- a/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- lib_mysqludf_fPROJ4.c.orig 2010-05-09 13:46:12.000000000 +0200
-+++ lib_mysqludf_fPROJ4.c 2011-10-19 02:32:48.000000000 +0200
-@@ -1,5 +1,3 @@
--/*
--
- /*
- lib_mysqludf_fPROJ4 - An extended set of scientific functions which
- converts geographic longitude and latitude coordinates into cartesian
-@@ -178,7 +176,7 @@
- }
- double fPROJ4_transform(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
- {
-- projPJ pj_in, pj_out;
-+ projPJ pj_in=NULL, pj_out=NULL;
- double x, y,z;
- int p,t;
-
-@@ -248,7 +246,7 @@
- }
- double fPROJ4_Geo2UTM(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
- {
-- projPJ pj_in, pj_out;
-+ projPJ pj_in=NULL, pj_out=NULL;
- double x, y;
- int p,t,zone;
- char *tmp;
-@@ -323,7 +321,7 @@
- }
- double fPROJ4_UTM2Geo(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
- {
-- projPJ pj_in, pj_out;
-+ projPJ pj_in=NULL, pj_out=NULL;
- double x, y;
- int p,t,zone;
- char *tmp;
diff --git a/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild b/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild
deleted file mode 100644
index 2dc76b444b43..000000000000
--- a/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MySQL UDFs which converts geographic/cartesian coordinates"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_fPROJ4/"
-SRC_URI="http://www.mysqludf.org/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1
- sci-libs/proj"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}-src"
-
-# compile helper
-_compile() {
- local CC="$(tc-getCC)"
- echo "${CC} ${@}" && "${CC}" "${@}"
-}
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-warnings.patch"
-
- # fix doc (BOM, CR/LF, soname)
- sed -i -e '1 s|^\xEF\xBB\xBF||' \
- -e "s|'\(${PN}\).*'|'\1.so'|g" ${PN}.sql
- echo >> ${PN}.sql # add LF
- edos2unix ${PN}.sql
-}
-
-src_compile() {
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} -lproj \
- -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
-}
-
-src_install() {
- exeinto "${MYSQL_PLUGINDIR}"
- doexe ${PN}.so
- dodoc ${PN}.sql
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}
diff --git a/dev-db/lib_mysqludf_fPROJ4/metadata.xml b/dev-db/lib_mysqludf_fPROJ4/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/dev-db/lib_mysqludf_fPROJ4/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/dev-db/lib_mysqludf_json/Manifest b/dev-db/lib_mysqludf_json/Manifest
deleted file mode 100644
index f650c2f7544c..000000000000
--- a/dev-db/lib_mysqludf_json/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lib_mysqludf_json_0.0.2.tar.gz 18177 BLAKE2B a998c99027a461a0cde53ec845f96531c0cfcfbf183c990a8736fd3f7c7911ad95b4e670fcf4178c4fe7b4c75b7f3a855a09b90a4a158fa72dd21805d153841d SHA512 04cc299498e7a7c40d2d181649e433c48be29f5dab2f46b64930f415060c3e05065d0d44d28ce0b35d190f3544687aa7e2ea66a69decc12609ec949bd78b8e05
diff --git a/dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild b/dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild
deleted file mode 100644
index 7e1fe812fcb9..000000000000
--- a/dev-db/lib_mysqludf_json/lib_mysqludf_json-0.0.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MySQL UDFs to map relational data to the JSON format"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_json/"
-SRC_URI="http://www.mysqludf.org/${PN}/${PN}_${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"
-
-# compile helper
-_compile() {
- local CC="$(tc-getCC)"
- echo "${CC} ${@}" && "${CC}" "${@}"
-}
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
- # remove precompiled object
- rm -f -- ${PN}.so
-}
-
-src_compile() {
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
- -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
-}
-
-src_install() {
- exeinto "${MYSQL_PLUGINDIR}"
- doexe ${PN}.so
- dodoc ${PN}.sql
- dohtml ${PN}.html
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}
diff --git a/dev-db/lib_mysqludf_json/metadata.xml b/dev-db/lib_mysqludf_json/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/dev-db/lib_mysqludf_json/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/dev-db/lib_mysqludf_preg/Manifest b/dev-db/lib_mysqludf_preg/Manifest
deleted file mode 100644
index 469ea1fcbc4a..000000000000
--- a/dev-db/lib_mysqludf_preg/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lib_mysqludf_preg-1.0.1.tar.gz 321868 BLAKE2B 64c87b1835488098e65164c4863bfc00356f033db62ca738bec99c483387044b8c4d89cd6e414a930948413599cab7dea0dab0cd20860f3d9438a148d384247b SHA512 36bb9c412d5f69040e5d4b3325a4b95e5e165010daea240c96611135b2c74dddb3e36bb6938c0684ecc30ff08151ce7543167a9e3a05e3e5cd0361102b1b083d
diff --git a/dev-db/lib_mysqludf_preg/lib_mysqludf_preg-1.0.1.ebuild b/dev-db/lib_mysqludf_preg/lib_mysqludf_preg-1.0.1.ebuild
deleted file mode 100644
index 327f16cebe4e..000000000000
--- a/dev-db/lib_mysqludf_preg/lib_mysqludf_preg-1.0.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs autotools
-
-DESCRIPTION="MySQL UDFs that provide access to the PCRE library for pattern matching"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_preg/"
-SRC_URI="http://www.mysqludf.org/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1
- dev-libs/libpcre"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
- edos2unix README
- eautoreconf
-}
-
-src_configure() {
- econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}"
-}
-
-src_install() {
- local X
- emake DESTDIR="${D}" install
- [ -f ${PN}.html ] && dohtml ${PN}.html
- [ -d doc/html ] && dohtml -r doc/html/.
- for X in API AUTHORS ChangeLog NEWS README *installdb.sql; do
- [ -s "${X}" ] && dodoc "${X}"
- done
-
- # remove obsolete *.la file
- rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}
diff --git a/dev-db/lib_mysqludf_preg/metadata.xml b/dev-db/lib_mysqludf_preg/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/dev-db/lib_mysqludf_preg/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/dev-db/lib_mysqludf_stat/Manifest b/dev-db/lib_mysqludf_stat/Manifest
deleted file mode 100644
index 6c7ada9c990a..000000000000
--- a/dev-db/lib_mysqludf_stat/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lib_mysqludf_stat_0.0.3.tar.gz 7325 BLAKE2B 8f111419277feb228ce2f5a05679f28cb50beebf2226b2a9b24667ac1621ff37d246e79fe66e3c061930dd7dcd3e940d927125f7c2792b001ea031ddfa061e26 SHA512 553a5f112c67fe773b27ca57c15611b5534ddc7babc0fff6e8771b106dc3037b9ca1459f9d2b201c53161037dc1e909b2a492fc0380340daddee098b5d82bd30
diff --git a/dev-db/lib_mysqludf_stat/files/lib_mysqludf_stat-warnings.patch b/dev-db/lib_mysqludf_stat/files/lib_mysqludf_stat-warnings.patch
deleted file mode 100644
index 5447356fea2d..000000000000
--- a/dev-db/lib_mysqludf_stat/files/lib_mysqludf_stat-warnings.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib_mysqludf_stat.c.orig 2011-10-19 04:30:24.000000000 +0200
-+++ lib_mysqludf_stat.c 2011-10-19 04:31:21.000000000 +0200
-@@ -550,7 +550,7 @@
- , char *error
- ){
- PEARSON* pearson_struct = (PEARSON *)initid->ptr;
-- double result;
-+ double result=0.0;
- if (pearson_struct->n==0){
- *is_null = 1;
- } else if (
-@@ -700,7 +700,7 @@
- POINT_BISERIAL_GROUP* X0;
- POINT_BISERIAL_GROUP* X1;
- double s;
-- double result;
-+ double result=0.0;
-
- point_biserial_struct = (POINT_BISERIAL *)initid->ptr;
- X = &point_biserial_struct->X;
diff --git a/dev-db/lib_mysqludf_stat/lib_mysqludf_stat-0.0.3.ebuild b/dev-db/lib_mysqludf_stat/lib_mysqludf_stat-0.0.3.ebuild
deleted file mode 100644
index f6c6fb36007d..000000000000
--- a/dev-db/lib_mysqludf_stat/lib_mysqludf_stat-0.0.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MySQL UDFs with statistical functions"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_stat/"
-SRC_URI="http://www.mysqludf.org/${PN}/${PN}_${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"
-
-# compile helper
-_compile() {
- local CC="$(tc-getCC)"
- echo "${CC} ${@}" && "${CC}" "${@}"
-}
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-warnings.patch"
-
- # remove precompiled object
- rm -f -- ${PN}.so
-}
-
-src_compile() {
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
- -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
-}
-
-src_install() {
- exeinto "${MYSQL_PLUGINDIR}"
- doexe ${PN}.so
- dodoc ${PN}.sql
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}
diff --git a/dev-db/lib_mysqludf_stat/metadata.xml b/dev-db/lib_mysqludf_stat/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/dev-db/lib_mysqludf_stat/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/dev-db/lib_mysqludf_str/Manifest b/dev-db/lib_mysqludf_str/Manifest
deleted file mode 100644
index b848d53725cd..000000000000
--- a/dev-db/lib_mysqludf_str/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lib_mysqludf_str-0.3.tar.gz 353717 BLAKE2B 7796b7930cb90ca4b088de81418fadc9d51a68681f8dcd1bd81a287427330f37fc880519a7486685b34c611d9f3b48d83370555f369c98853015557b3d5d458a SHA512 a63ffbfd352db087da5a3e70f713845a88c6f4db47511a5b359bb8bcb466070d34b5e2b16d2bde38bd617ed209e2dc4553bbccfb406820e7669aa688652332b8
diff --git a/dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild b/dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild
deleted file mode 100644
index 599c50b6457c..000000000000
--- a/dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs autotools
-
-DESCRIPTION="MySQL UDFs of string functions that complement the set of native ones"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_str/"
-SRC_URI="http://www.mysqludf.org/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
- edos2unix README
- eautoreconf
-}
-
-src_configure() {
- econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- [ -f ${PN}.html ] && dohtml ${PN}.html
- [ -d doc/html ] && dohtml -r doc/html/.
- for X in API AUTHORS ChangeLog NEWS README *installdb.sql; do
- [ -s "${X}" ] && dodoc "${X}"
- done
-
- # remove obsolete *.la file
- rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}
diff --git a/dev-db/lib_mysqludf_str/metadata.xml b/dev-db/lib_mysqludf_str/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/dev-db/lib_mysqludf_str/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/dev-db/lib_mysqludf_sys/Manifest b/dev-db/lib_mysqludf_sys/Manifest
deleted file mode 100644
index 99c270a61b8e..000000000000
--- a/dev-db/lib_mysqludf_sys/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lib_mysqludf_sys_0.0.3.tar.gz 9136 BLAKE2B 1160ebde8a3cb23769d7c961b124469a60527717996b9ccdc49f636950b28a03c577ec4da1f65a5eda4105d1b8b7a49d445f6a3735ad108fdf469f67d7a78a3c SHA512 17154007bc315b7f5c98ed4eb0f6305a1c2bbd4a66a3b6985ed4547baddffcaac71a384fcce0780e26968021439f32534160661a5db756a012763b2ac74a3060
diff --git a/dev-db/lib_mysqludf_sys/lib_mysqludf_sys-0.0.3.ebuild b/dev-db/lib_mysqludf_sys/lib_mysqludf_sys-0.0.3.ebuild
deleted file mode 100644
index 9a99af98128d..000000000000
--- a/dev-db/lib_mysqludf_sys/lib_mysqludf_sys-0.0.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MySQL UDFs that allows one to interact with the operating system"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_sys/"
-SRC_URI="http://www.mysqludf.org/${PN}/${PN}_${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"
-
-# compile helper
-_compile() {
- local CC="$(tc-getCC)"
- echo "${CC} ${@}" && "${CC}" "${@}"
-}
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
- # remove precompiled object
- rm -f -- ${PN}.so
-}
-
-src_compile() {
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
- -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
-}
-
-src_install() {
- exeinto "${MYSQL_PLUGINDIR}"
- doexe ${PN}.so
- dodoc ${PN}.sql
- dohtml ${PN}.html
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}
diff --git a/dev-db/lib_mysqludf_sys/metadata.xml b/dev-db/lib_mysqludf_sys/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/dev-db/lib_mysqludf_sys/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/dev-db/lib_mysqludf_ta/Manifest b/dev-db/lib_mysqludf_ta/Manifest
deleted file mode 100644
index d8197d2d334c..000000000000
--- a/dev-db/lib_mysqludf_ta/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST joaocosta-lib_mysqludf_ta-a8e623c.tar.gz 932876 BLAKE2B 43bae3847185ae5994c2899a900ac3c099cf8de15beec559968e43705b2e12df8a5b0105b1a453f3ccddfdb22cca9b391db5c50fc6b37e64b72deb692ab79786 SHA512 4e8422067a055b55bdd1e7103f925f47b8174a83bd20d337d3f39479eebba3de9da0dc8a382441c090c6ef86b03e965d34a38b4c0f3ecc14ad0408aa2cdf511a
diff --git a/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild b/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild
deleted file mode 100644
index 1d60af33a1e3..000000000000
--- a/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs autotools
-
-MY_REV="a8e623c" # checkout revision
-MY_USR="joaocosta" # user name
-
-MY_P="${MY_USR}-${PN}-${MY_REV}"
-
-DESCRIPTION="MySQL UDFs with technical analysis functions"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_ta/"
-SRC_URI="https://github.com/${MY_USR}/${PN}/tarball/${MY_REV} -> ${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_prepare() {
-
- # fix Makefile.am
- sed -i -e "s|\(-shared\)|\1 -avoid-version|g" Makefile.am
-
- # convert to UTF-8
- iconv -f LATIN1 -t UTF-8 < README > README~
- mv -f README~ README
-
- edos2unix README
- eautoreconf
-}
-
-src_configure() {
- econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc README sampledb.sql
-
- # remove obsolete *.la file
- rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}
diff --git a/dev-db/lib_mysqludf_ta/metadata.xml b/dev-db/lib_mysqludf_ta/metadata.xml
deleted file mode 100644
index cc95dc0337f7..000000000000
--- a/dev-db/lib_mysqludf_ta/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">joaocosta/lib_mysqludf_ta</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-db/lib_mysqludf_udf/Manifest b/dev-db/lib_mysqludf_udf/Manifest
deleted file mode 100644
index 437e67cded16..000000000000
--- a/dev-db/lib_mysqludf_udf/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lib_mysqludf_udf_0.0.3.tar.gz 2516 BLAKE2B 56423a53ae04090db6a83a471dcad308e06b4df43fb7f36353c7d417273e1794574bc012b22e93935ad2fa38e2c966ebbab640e68743705464eb5afa02eecd63 SHA512 5fdaa12b3846eb3921f8fbdf9001706155287066dd488fff2bb8419b306b20cad24e677224368c80e3f3af0379a4038e5a532d855ce16366c7a152cd1127c162
diff --git a/dev-db/lib_mysqludf_udf/lib_mysqludf_udf-0.0.3.ebuild b/dev-db/lib_mysqludf_udf/lib_mysqludf_udf-0.0.3.ebuild
deleted file mode 100644
index e5858d5dae8f..000000000000
--- a/dev-db/lib_mysqludf_udf/lib_mysqludf_udf-0.0.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MySQL UDFs for reporting internals from the udf interface"
-HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_udf/"
-SRC_URI="http://www.mysqludf.org/${PN}/${PN}_${PV}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=virtual/mysql-5.1"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}"
-
-# compile helper
-_compile() {
- local CC="$(tc-getCC)"
- echo "${CC} ${@}" && "${CC}" "${@}"
-}
-
-pkg_setup() {
- MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
- MYSQL_INCLUDE="$(mysql_config --include)"
-}
-
-src_compile() {
- _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
- -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
-}
-
-src_install() {
- exeinto "${MYSQL_PLUGINDIR}"
- doexe ${PN}.so
- dodoc ${PN}.sql
-}
-
-pkg_postinst() {
- elog
- elog "Please have a look at the documentation, how to"
- elog "enable/disable the UDF functions of ${PN}."
- elog
- elog "The documentation is located here:"
- elog "/usr/share/doc/${PF}"
- elog
-}
diff --git a/dev-db/lib_mysqludf_udf/metadata.xml b/dev-db/lib_mysqludf_udf/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/dev-db/lib_mysqludf_udf/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>