summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild')
-rw-r--r--dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild b/dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild
new file mode 100644
index 000000000000..aa5d30bbef37
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit mono
+
+DESCRIPTION="Taglib# 2.0 - Managed tag reader/writer"
+HOMEPAGE="http://download.banshee.fm/taglib-sharp/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ sed -i -e "s:docs::" \
+ -e "s:examples::" \
+ Makefile.in || die "sedding sense into makefiles failed"
+}
+
+src_configure() {
+ econf --disable-docs
+}