summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/guichan/guichan-0.8.2.ebuild')
-rw-r--r--dev-games/guichan/guichan-0.8.2.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/dev-games/guichan/guichan-0.8.2.ebuild b/dev-games/guichan/guichan-0.8.2.ebuild
index 049a09d0547b..9ecf5c198b84 100644
--- a/dev-games/guichan/guichan-0.8.2.ebuild
+++ b/dev-games/guichan/guichan-0.8.2.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools ltprune
+EAPI=7
-DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
+inherit autotools
+
+DESCRIPTION="A portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
HOMEPAGE="http://guichan.sourceforge.net/"
SRC_URI="https://guichan.googlecode.com/files/${P}.tar.gz"
@@ -13,18 +14,24 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="allegro opengl sdl static-libs"
-DEPEND="allegro? ( <media-libs/allegro-5 )
+DEPEND="
+ allegro? ( media-libs/allegro:0 )
opengl? ( virtual/opengl )
sdl? (
media-libs/libsdl
media-libs/sdl-image
)"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ "${FILESDIR}"/${P}-slibtool-undefined-references.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-as-needed.patch \
- "${FILESDIR}"/${P}-automake-1.13.patch
+ default
+
mv configure.in configure.ac || die
eautoreconf
}
@@ -40,5 +47,6 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+
+ find "${ED}" -name '*.la' -delete || die
}