summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-gitlab-client/go-gitlab-client-0_pre20160305.ebuild')
-rw-r--r--dev-go/go-gitlab-client/go-gitlab-client-0_pre20160305.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-go/go-gitlab-client/go-gitlab-client-0_pre20160305.ebuild b/dev-go/go-gitlab-client/go-gitlab-client-0_pre20160305.ebuild
new file mode 100644
index 000000000000..857e28868809
--- /dev/null
+++ b/dev-go/go-gitlab-client/go-gitlab-client-0_pre20160305.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/plouc/go-gitlab-client/..."
+EGIT_COMMIT="a526ef09e9e03f673a43ecd4a687abf6c25343ca"
+ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="A simple gitlab api client written in Go"
+HOMEPAGE="https://github.com/plouc/go-gitlab-client"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0/${PVR}"
+IUSE=""
+
+# Requires dev-go/testify to be packaged
+RESTRICT="test"