summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-md2man/go-md2man-2.0.0.ebuild')
-rw-r--r--dev-go/go-md2man/go-md2man-2.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/go-md2man/go-md2man-2.0.0.ebuild b/dev-go/go-md2man/go-md2man-2.0.0.ebuild
new file mode 100644
index 000000000000..09492c139365
--- /dev/null
+++ b/dev-go/go-md2man/go-md2man-2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="A utility to convert markdown to man pages"
+ SRC_URI="https://github.com/cpuguy83/go-md2man/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/cpuguy83/go-md2man"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+
+src_compile() {
+ emake BUILD_FLAGS="-mod=vendor" build
+}
+
+src_install() {
+ "${S}"/bin/go-md2man -in go-md2man.1.md -out go-md2man.1 || ||
+ die "Unable to create man page"
+ dobin bin/go-md2man
+ doman go-md2man.1
+}