summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/logrus/logrus-1.4.1.ebuild')
-rw-r--r--dev-go/logrus/logrus-1.4.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-go/logrus/logrus-1.4.1.ebuild b/dev-go/logrus/logrus-1.4.1.ebuild
new file mode 100644
index 000000000000..f7b7b05c129a
--- /dev/null
+++ b/dev-go/logrus/logrus-1.4.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN=github.com/sirupsen/logrus
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Structured, pluggable logging for Go"
+HOMEPAGE="https://github.com/sirupsen/logrus"
+LICENSE="MIT"
+SLOT="0"
+DEPEND="dev-go/go-sys:="
+RDEPEND=""