summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/adjunctions')
-rw-r--r--dev-haskell/adjunctions/Manifest2
-rw-r--r--dev-haskell/adjunctions/adjunctions-4.2.1.ebuild36
-rw-r--r--dev-haskell/adjunctions/adjunctions-4.2.ebuild36
-rw-r--r--dev-haskell/adjunctions/metadata.xml11
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-haskell/adjunctions/Manifest b/dev-haskell/adjunctions/Manifest
new file mode 100644
index 000000000000..05f268363d3b
--- /dev/null
+++ b/dev-haskell/adjunctions/Manifest
@@ -0,0 +1,2 @@
+DIST adjunctions-4.2.1.tar.gz 14314 SHA256 65a64cd42dcf356c2b44fffc4360f8cbf494702f7574b5a1e57e1864b0f8f46f SHA512 e287716e6399201a331f9c7dbd000e06aa1dabedb7a6c41a9d336bd85fde78b810d2181554199dbbd61ef42d7b6429612032fd51c92ed5d6ea8d7f49b59afe25 WHIRLPOOL 08f490379af7cab42c4934ebfea39bbd610bb1b0b39ca1f83e289ecab057d209e15e6aa4664bf5744a330561514167b1ae6f75f5a88e9c3a58929d7966ba35c4
+DIST adjunctions-4.2.tar.gz 14300 SHA256 31c9988b9e76fa342bff9314af5fd088f99bcaf6d66adb3ba3dc343f4d36251f SHA512 019f5e92982723edcc371e303aeaf9d04f5245b979feb1f17eb6c1a1af4a2982a6bde98f59b705b080b547c64349637e8acc43ebe913cc10c98a636be30ee505 WHIRLPOOL 5b2f480443f50ec52f037008a52e5920c393dcae7f3c45744625f7693e3c8c81c2f1604c54e4318e0f3e9c3d3b7f3ecc80b495c5b9050eb2dc2498ba2ff55002
diff --git a/dev-haskell/adjunctions/adjunctions-4.2.1.ebuild b/dev-haskell/adjunctions/adjunctions-4.2.1.ebuild
new file mode 100644
index 000000000000..feff6b68b995
--- /dev/null
+++ b/dev-haskell/adjunctions/adjunctions-4.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Adjunctions and representable functors"
+HOMEPAGE="http://github.com/ekmett/adjunctions/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/comonad-4:=[profile?] <dev-haskell/comonad-5:=[profile?]
+ >=dev-haskell/contravariant-1:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/distributive-0.4:=[profile?] <dev-haskell/distributive-1:=[profile?]
+ >=dev-haskell/free-4:=[profile?] <dev-haskell/free-5:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/profunctors-4:=[profile?] <dev-haskell/profunctors-6:=[profile?]
+ >=dev-haskell/semigroupoids-4:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
+ >=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/void-0.5.5.1:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/adjunctions/adjunctions-4.2.ebuild b/dev-haskell/adjunctions/adjunctions-4.2.ebuild
new file mode 100644
index 000000000000..1cfa19e79c2e
--- /dev/null
+++ b/dev-haskell/adjunctions/adjunctions-4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Adjunctions and representable functors"
+HOMEPAGE="http://github.com/ekmett/adjunctions/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/comonad-4:=[profile?] <dev-haskell/comonad-5:=[profile?]
+ >=dev-haskell/contravariant-1:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/distributive-0.4:=[profile?] <dev-haskell/distributive-1:=[profile?]
+ >=dev-haskell/free-4:=[profile?] <dev-haskell/free-5:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/profunctors-4:=[profile?] <dev-haskell/profunctors-5:=[profile?]
+ >=dev-haskell/semigroupoids-4:=[profile?] <dev-haskell/semigroupoids-5:=[profile?]
+ >=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-haskell/void-0.5.5.1:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/adjunctions/metadata.xml b/dev-haskell/adjunctions/metadata.xml
new file mode 100644
index 000000000000..c9ee4d2c6368
--- /dev/null
+++ b/dev-haskell/adjunctions/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Adjunctions
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ekmett/adjunctions</remote-id>
+ </upstream>
+</pkgmetadata>