summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild')
-rw-r--r--dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild b/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild
new file mode 100644
index 000000000000..90fe1d29f555
--- /dev/null
+++ b/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="http://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/asn1-types-0.2.1:=[profile?] <dev-haskell/asn1-types-0.3:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2:2=[profile?]
+ >=dev-haskell/test-framework-0.3:=[profile?]
+ >=dev-haskell/test-framework-quickcheck2-0.2:=[profile?] )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}