summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/blaze-textual/blaze-textual-0.2.1.0.ebuild')
-rw-r--r--dev-haskell/blaze-textual/blaze-textual-0.2.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/blaze-textual/blaze-textual-0.2.1.0.ebuild b/dev-haskell/blaze-textual/blaze-textual-0.2.1.0.ebuild
new file mode 100644
index 000000000000..b83befa93abe
--- /dev/null
+++ b/dev-haskell/blaze-textual/blaze-textual-0.2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -developer,-native
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast rendering of common datatypes"
+HOMEPAGE="https://github.com/bos/blaze-textual"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # fails tests
+
+RDEPEND=">=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ >=dev-haskell/double-conversion-0.2.0.1:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ >=dev-haskell/text-0.11.0.2:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.4.0.1
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer \
+ --flag=-native
+}