summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild')
-rw-r--r--dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild b/dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild
new file mode 100644
index 000000000000..cb2fc880e6bf
--- /dev/null
+++ b/dev-haskell/c2hs/c2hs-0.16.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+CABAL_FEATURES="bin"
+inherit base haskell-cabal
+
+DESCRIPTION="C->Haskell FFI tool that gives some cross-language type safety"
+HOMEPAGE="http://www.cse.unsw.edu.au/~chak/haskell/c2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.6.1
+ >=dev-haskell/cabal-1.6
+ >=dev-haskell/language-c-0.3.1.1 <dev-haskell/language-c-0.5
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets
+ >=dev-libs/libxslt-1.1.2 )"
+RDEPEND="dev-libs/gmp"
+
+PATCHES=("${FILESDIR}/${PN}"-0.16.3-language-c-0.4.patch
+ "${FILESDIR}/${PN}"-0.16.3-ghc-7.6.patch)
+
+src_compile() {
+ cabal_src_compile
+
+ if use doc; then
+ emake -C doc
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/doc/man1/c2hs.1"
+
+ if use doc; then
+ dohtml "${S}/doc/users_guide/"*
+ fi
+}