summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cmark/cmark-0.5.6.ebuild')
-rw-r--r--dev-haskell/cmark/cmark-0.5.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/cmark/cmark-0.5.6.ebuild b/dev-haskell/cmark/cmark-0.5.6.ebuild
new file mode 100644
index 000000000000..be8838bc8570
--- /dev/null
+++ b/dev-haskell/cmark/cmark-0.5.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+#hackport: flags: pkgconfig:system-cmark
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, accurate CommonMark (Markdown) parser and renderer"
+HOMEPAGE="https://github.com/jgm/cmark-hs"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+system-cmark"
+
+RDEPEND=">=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ system-cmark? ( app-text/cmark )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7 )
+ system-cmark? ( virtual/pkgconfig )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag system-cmark pkgconfig)
+}