summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cpu/cpu-0.1.2.ebuild')
-rw-r--r--dev-haskell/cpu/cpu-0.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/cpu/cpu-0.1.2.ebuild b/dev-haskell/cpu/cpu-0.1.2.ebuild
new file mode 100644
index 000000000000..f8d898eb29ac
--- /dev/null
+++ b/dev-haskell/cpu/cpu-0.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Cpu information and properties helpers"
+HOMEPAGE="http://github.com/vincenthz/hs-cpu"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}