summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cryptonite/cryptonite-0.7.ebuild')
-rw-r--r--dev-haskell/cryptonite/cryptonite-0.7.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-haskell/cryptonite/cryptonite-0.7.ebuild b/dev-haskell/cryptonite/cryptonite-0.7.ebuild
deleted file mode 100644
index bf70362d04a2..000000000000
--- a/dev-haskell/cryptonite/cryptonite-0.7.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.4.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Cryptography Primitives sink"
-HOMEPAGE="https://github.com/vincenthz/cryptonite"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+integer-gmp +support_aesni +support_deepseq support_pclmuldq +support_rdrand"
-
-RESTRICT=test # slow
-
-RDEPEND=">=dev-haskell/memory-0.8:=[profile?]
- >=dev-lang/ghc-7.4.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.10
- test? ( dev-haskell/byteable
- dev-haskell/tasty
- dev-haskell/tasty-hunit
- dev-haskell/tasty-kat
- dev-haskell/tasty-quickcheck )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag integer-gmp integer-gmp) \
- $(cabal_flag support_aesni support_aesni) \
- $(cabal_flag support_deepseq support_deepseq) \
- $(cabal_flag support_pclmuldq support_pclmuldq) \
- $(cabal_flag support_rdrand support_rdrand)
-}