summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/dbus')
-rw-r--r--dev-haskell/dbus/Manifest3
-rw-r--r--dev-haskell/dbus/dbus-0.10.10.ebuild37
-rw-r--r--dev-haskell/dbus/dbus-0.10.5-r1.ebuild39
-rw-r--r--dev-haskell/dbus/dbus-0.10.9.2.ebuild37
-rw-r--r--dev-haskell/dbus/metadata.xml61
5 files changed, 177 insertions, 0 deletions
diff --git a/dev-haskell/dbus/Manifest b/dev-haskell/dbus/Manifest
new file mode 100644
index 000000000000..0454ed108324
--- /dev/null
+++ b/dev-haskell/dbus/Manifest
@@ -0,0 +1,3 @@
+DIST dbus-0.10.10.tar.gz 73707 SHA256 cd68c5613fbad01a31be17501e2b4cf242b09625d5fed9474db6c4b5c4f22468 SHA512 c2faa76c32abb19ab903c015f6fc133beb605bbb4459d018fa544ffe4e04110cc63fc45815d862e8311f5b99de9c180c8eeb8e135fd6c7eb388ff579529a8ead WHIRLPOOL 919905324f7910a9b0a4ef77ca418a6610f974b79941141822eab8eb7c2505b918868f0a74c33d5d928612992ba6d03ad6889cd9fd3e726b57181247a252abef
+DIST dbus-0.10.5.tar.gz 73715 SHA256 3d103e5f119ca15ebb64ca43e10d7a96ab6b010715132b3eec6b6c4ef9c474f1 SHA512 be0c78cf042e536c7a9e8630259f209a8d7bd1f1e0e8b653ab53dea63460e92a4158efcb9808c336bb82a7b6e473bc5148245890f47b2f826a7b6a0c1ca06d92 WHIRLPOOL bbc67894b56146a0454a4c87f47b99b719b2fda71e6f3a8fe8ec1d72ce364931dc7b3196bc8e5bc882b743cbeb9873026382092d4699a244302c2f2b9baeaa73
+DIST dbus-0.10.9.2.tar.gz 73294 SHA256 d4c888d03e32d590528e8b7452cba9dc3fc3c675318215840dbb66f4a48ae177 SHA512 b72f1f3676dcefbc22677899cbd148f068ac49951ec8821f7b0c1e0e026964fc1a6060c8ab83943ef9ff92529fd6726d653b788f1a0eaf0edf71ac0d61cec7fa WHIRLPOOL 6d9872e88c4921d89b316f7275bf5e37619096b70772ade000a8b237473da6e315b7ae23c4836dabbfd169c3d30b7dda00a497aae0172f299590c10c0305852c
diff --git a/dev-haskell/dbus/dbus-0.10.10.ebuild b/dev-haskell/dbus/dbus-0.10.10.ebuild
new file mode 100644
index 000000000000..4cca143db899
--- /dev/null
+++ b/dev-haskell/dbus/dbus-0.10.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A client library for the D-Bus IPC system"
+HOMEPAGE="https://john-millikin.com/software/haskell-dbus/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.3.4:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/libxml-sax-0.7:=[profile?] <dev-haskell/libxml-sax-0.8:=[profile?]
+ >=dev-haskell/network-2.2.3:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-2.0:=[profile?]
+ >=dev-haskell/text-0.11.1.5:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/xml-types-0.3:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.4 <dev-haskell/chell-0.5
+ >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3
+ >=dev-haskell/quickcheck-2.4 )
+"
diff --git a/dev-haskell/dbus/dbus-0.10.5-r1.ebuild b/dev-haskell/dbus/dbus-0.10.5-r1.ebuild
new file mode 100644
index 000000000000..5820d8238605
--- /dev/null
+++ b/dev-haskell/dbus/dbus-0.10.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A client library for the D-Bus IPC system"
+HOMEPAGE="https://john-millikin.com/software/haskell-dbus/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.3.4:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/libxml-sax-0.7:=[profile?] <dev-haskell/libxml-sax-0.8:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.1:=[profile?]
+ >=dev-haskell/text-0.11.1.5:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/xml-types-0.3:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ >=dev-haskell/network-2.2.3:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'text >= 0.11.1.5 && < 0.12' 'text >= 0.11.1.5'
+}
diff --git a/dev-haskell/dbus/dbus-0.10.9.2.ebuild b/dev-haskell/dbus/dbus-0.10.9.2.ebuild
new file mode 100644
index 000000000000..f3e7aff8fa04
--- /dev/null
+++ b/dev-haskell/dbus/dbus-0.10.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A client library for the D-Bus IPC system"
+HOMEPAGE="https://john-millikin.com/software/haskell-dbus/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.3.4:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/libxml-sax-0.7:=[profile?] <dev-haskell/libxml-sax-0.8:=[profile?]
+ >=dev-haskell/network-2.2.3:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-2.0:=[profile?]
+ >=dev-haskell/text-0.11.1.5:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/xml-types-0.3:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/chell-0.4 <dev-haskell/chell-0.5
+ >=dev-haskell/chell-quickcheck-0.2 <dev-haskell/chell-quickcheck-0.3
+ >=dev-haskell/quickcheck-2.4 )
+"
diff --git a/dev-haskell/dbus/metadata.xml b/dev-haskell/dbus/metadata.xml
new file mode 100644
index 000000000000..205ed770c91e
--- /dev/null
+++ b/dev-haskell/dbus/metadata.xml
@@ -0,0 +1,61 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ D-Bus is a simple, message-based protocol for inter-process
+ communication, which allows applications to interact with other parts of
+ the machine and the user&#39;s session using remote procedure calls.
+
+ D-Bus is a essential part of the modern Linux desktop, where it replaces
+ earlier protocols such as CORBA and DCOP.
+
+ This library is an implementation of the D-Bus protocol in Haskell. It
+ can be used to add D-Bus support to Haskell applications, without the
+ awkward interfaces common to foreign bindings.
+
+ Example: connect to the session bus, and get a list of active names.
+
+ @
+ &amp;#x7b;-\# LANGUAGE OverloadedStrings \#-&amp;#x7d;
+
+ import Data.List (sort)
+ import DBus
+ import DBus.Client
+
+ main = do
+ &amp;#x20; client &lt;- connectSession
+ &amp;#x20; //
+ &amp;#x20; \-- Request a list of connected clients from the bus
+ &amp;#x20; reply &lt;- call_ client (methodCall \&quot;\/org\/freedesktop\/DBus\&quot; \&quot;org.freedesktop.DBus\&quot; \&quot;ListNames\&quot;)
+ &amp;#x20; &amp;#x7b; methodCallDestination = Just \&quot;org.freedesktop.DBus\&quot;
+ &amp;#x20; &amp;#x7d;
+ &amp;#x20; //
+ &amp;#x20; \-- org.freedesktop.DBus.ListNames() returns a single value, which is
+ &amp;#x20; \-- a list of names (here represented as [String])
+ &amp;#x20; let Just names = fromVariant (methodReturnBody reply !! 0)
+ &amp;#x20; //
+ &amp;#x20; \-- Print each name on a line, sorted so reserved names are below
+ &amp;#x20; \-- temporary names.
+ &amp;#x20; mapM_ putStrLn (sort names)
+ @
+
+ &gt;$ ghc --make list-names.hs
+ &gt;$ ./list-names
+ &gt;:1.0
+ &gt;:1.1
+ &gt;:1.10
+ &gt;:1.106
+ &gt;:1.109
+ &gt;:1.110
+ &gt;ca.desrt.dconf
+ &gt;org.freedesktop.DBus
+ &gt;org.freedesktop.Notifications
+ &gt;org.freedesktop.secrets
+ &gt;org.gnome.ScreenSaver
+ </longdescription>
+</pkgmetadata>