summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hscolour/hscolour-1.20.3-r1.ebuild')
-rw-r--r--dev-haskell/hscolour/hscolour-1.20.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/hscolour/hscolour-1.20.3-r1.ebuild b/dev-haskell/hscolour/hscolour-1.20.3-r1.ebuild
new file mode 100644
index 000000000000..b13f8fbd6f70
--- /dev/null
+++ b/dev-haskell/hscolour/hscolour-1.20.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+# disabled haddock as there is USE="doc hscolour" case with circular depends
+CABAL_FEATURES="bin lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="Colourise Haskell code"
+HOMEPAGE="http://code.haskell.org/~malcolm/hscolour/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure --ghc-options=-rtsopts
+}
+
+src_install() {
+ cabal_src_install
+ if use doc; then
+ dohtml hscolour.css
+ fi
+}