summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hspec/hspec-1.8.1.1.ebuild')
-rw-r--r--dev-haskell/hspec/hspec-1.8.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/hspec/hspec-1.8.1.1.ebuild b/dev-haskell/hspec/hspec-1.8.1.1.ebuild
new file mode 100644
index 000000000000..c98599449b86
--- /dev/null
+++ b/dev-haskell/hspec/hspec-1.8.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Behavior-Driven Development for Haskell"
+HOMEPAGE="http://hspec.github.io/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.5:=[profile?]
+ >=dev-haskell/hspec-expectations-0.5.0:=[profile?] <dev-haskell/hspec-expectations-0.5.1:=[profile?]
+ >=dev-haskell/hunit-1.2.5:=[profile?]
+ >=dev-haskell/quickcheck-2.5.1:=[profile?]
+ dev-haskell/quickcheck-io:=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.1:=[profile?]
+ dev-haskell/setenv:=[profile?]
+ >=dev-haskell/transformers-0.2.2.0:=[profile?] <dev-haskell/transformers-0.4.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/doctest-0.9.4.1
+ dev-haskell/ghc-paths
+ >=dev-haskell/hspec-meta-1.8.0
+ >=dev-haskell/silently-1.2.4 )
+"