summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild')
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild
new file mode 100644
index 000000000000..9a8bbded77ea
--- /dev/null
+++ b/dev-haskell/lhs2tex/lhs2tex-1.18.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="bin"
+inherit base haskell-cabal
+
+DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
+HOMEPAGE="http://www.andres-loeh.de/lhs2tex/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# dev-texlive/texlive-mathextra contains 'stmaryrd' font used
+# for guide generation
+RDEPEND=">=dev-tex/polytable-0.8.2
+ dev-texlive/texlive-mathextra"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ dev-haskell/mtl
+ dev-haskell/regex-compat
+ >=dev-lang/ghc-6.12.1"
+
+# Setup.hs uses 'Text.Regex' available in both 'r-c' and 'r-c-tdfa'
+HCFLAGS+=" -ignore-package=regex-compat-tdfa"
+
+# datadir is /usr/share/${PN}/${GHC_VER} so mandir is ${DATADIR}/../../man
+PATCHES=("${FILESDIR}/${PN}-1.18.1-mandir.patch")