summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/mutable-containers/mutable-containers-0.3.2.ebuild')
-rw-r--r--dev-haskell/mutable-containers/mutable-containers-0.3.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/mutable-containers/mutable-containers-0.3.2.ebuild b/dev-haskell/mutable-containers/mutable-containers-0.3.2.ebuild
new file mode 100644
index 000000000000..dc29fa8cdf95
--- /dev/null
+++ b/dev-haskell/mutable-containers/mutable-containers-0.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Abstactions and concrete implementations of mutable containers"
+HOMEPAGE="https://github.com/fpco/mutable-containers"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/mono-traversable:=[profile?]
+ >=dev-haskell/primitive-0.5.2.1:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hspec
+ dev-haskell/quickcheck )
+"