summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/mwc-random/mwc-random-0.13.2.2.ebuild')
-rw-r--r--dev-haskell/mwc-random/mwc-random-0.13.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/mwc-random/mwc-random-0.13.2.2.ebuild b/dev-haskell/mwc-random/mwc-random-0.13.2.2.ebuild
new file mode 100644
index 000000000000..ee893d4acb53
--- /dev/null
+++ b/dev-haskell/mwc-random/mwc-random-0.13.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, high quality pseudo random number generation"
+HOMEPAGE="https://github.com/bos/mwc-random"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # breaks when installed mwc-random is broken
+
+RDEPEND="dev-haskell/primitive:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ >=dev-haskell/statistics-0.10.1.0
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"