summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/tasty/tasty-0.2.ebuild')
-rw-r--r--dev-haskell/tasty/tasty-0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/tasty/tasty-0.2.ebuild b/dev-haskell/tasty/tasty-0.2.ebuild
new file mode 100644
index 000000000000..df94262aaf2f
--- /dev/null
+++ b/dev-haskell/tasty/tasty-0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="http://hackage.haskell.org/package/tasty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+colors"
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-haskell/optparse-applicative-0.5:=[profile?]
+ dev-haskell/regex-posix:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/tagged:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ colors? ( dev-haskell/ansi-terminal:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag colors colors)
+}