summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/wxhaskell/wxhaskell-0.90.0.1.ebuild')
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.90.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.90.0.1.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.90.0.1.ebuild
new file mode 100644
index 000000000000..66a7383af4b6
--- /dev/null
+++ b/dev-haskell/wxhaskell/wxhaskell-0.90.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.9"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN=wx
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="wxHaskell is a portable and native GUI library for Haskell"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxcore-0.90:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"