summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/yesod-persistent')
-rw-r--r--dev-haskell/yesod-persistent/Manifest3
-rw-r--r--dev-haskell/yesod-persistent/metadata.xml8
-rw-r--r--dev-haskell/yesod-persistent/yesod-persistent-1.2.3.ebuild38
-rw-r--r--dev-haskell/yesod-persistent/yesod-persistent-1.4.0.2.ebuild37
-rw-r--r--dev-haskell/yesod-persistent/yesod-persistent-1.4.0.3.ebuild37
5 files changed, 123 insertions, 0 deletions
diff --git a/dev-haskell/yesod-persistent/Manifest b/dev-haskell/yesod-persistent/Manifest
new file mode 100644
index 000000000000..ef41c0bd7c52
--- /dev/null
+++ b/dev-haskell/yesod-persistent/Manifest
@@ -0,0 +1,3 @@
+DIST yesod-persistent-1.2.3.tar.gz 4169 SHA256 fc3627ff021573cb92403b667e20ebb6194b227f30a189019d288be1cdbfbacd SHA512 b7e7f6734ef0a61c61dbbe00d4496ca5ee51a389eaf0f32b2d6092f4662ca810cc051ed47b9976c35b69ca939dec858f1b70f6de8309a3e45486ef914ab329a3 WHIRLPOOL 9c05deefaf7b800463dfeb6551c8a86ad77072b5a29e001ee41680c6697bb9372fe1dab927b2375839f404f75dfdfef0f3b846fade132f149722958ea48ac73a
+DIST yesod-persistent-1.4.0.2.tar.gz 4254 SHA256 2b52136573723bbd85b0d51ea016b13da4fe2ba087406a3082609e55017e1f1b SHA512 66d44f6229b4cb8539106c31d91d827bdb89027b6bb86f1ed2252a05847bca51d86c56edb2fac4120e9d39c83b77aba19ebb80ee72420923e2a8d66f218f3a25 WHIRLPOOL c896612b63c4287015e56e4f02d77bfd1bc230f2bdde858aa836f73abd2c8f363d904f866dc44ef284e2fe18eb569b9e82d34d7db0d9cef2b89726ecaaa7f5b7
+DIST yesod-persistent-1.4.0.3.tar.gz 4283 SHA256 6455b79eda028e12caefc9d89808fbc611ece36ef64bab3426f90a26cacf3b5f SHA512 9701fd77fe40862f712a3f2ff7108203c2a1532bea03c1d63396c0133fb24b2adc70d134b22f7e61a1e5c96a8a8859f131eea0e180fe9e731dd2d0ca8d47b0ae WHIRLPOOL ed436bcf4db489f89c1935ce9240b31cc6e4a08d12d24c183db4c3221151502f37ec32e7a5114244a86404192bb22ebb625d85406d716f5d441faeacf234ba16
diff --git a/dev-haskell/yesod-persistent/metadata.xml b/dev-haskell/yesod-persistent/metadata.xml
new file mode 100644
index 000000000000..2966c2ba2b93
--- /dev/null
+++ b/dev-haskell/yesod-persistent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Some helpers for using Persistent from Yesod.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/yesod-persistent/yesod-persistent-1.2.3.ebuild b/dev-haskell/yesod-persistent/yesod-persistent-1.2.3.ebuild
new file mode 100644
index 000000000000..b88a9627f38b
--- /dev/null
+++ b/dev-haskell/yesod-persistent/yesod-persistent-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Some helpers for using Persistent from Yesod"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ >=dev-haskell/persistent-1.2:=[profile?] <dev-haskell/persistent-1.4:=[profile?]
+ >=dev-haskell/persistent-template-1.2:=[profile?] <dev-haskell/persistent-template-1.4:=[profile?]
+ dev-haskell/resource-pool:=[profile?]
+ >=dev-haskell/resourcet-0.4.5:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/yesod-core-1.2.2:=[profile?] <dev-haskell/yesod-core-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec
+ dev-haskell/persistent-sqlite
+ dev-haskell/text
+ dev-haskell/wai-extra
+ dev-haskell/wai-test )
+"
diff --git a/dev-haskell/yesod-persistent/yesod-persistent-1.4.0.2.ebuild b/dev-haskell/yesod-persistent/yesod-persistent-1.4.0.2.ebuild
new file mode 100644
index 000000000000..e2fff4c4aa6f
--- /dev/null
+++ b/dev-haskell/yesod-persistent/yesod-persistent-1.4.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Some helpers for using Persistent from Yesod"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.2:=[profile?]
+ >=dev-haskell/persistent-template-2.1:=[profile?] <dev-haskell/persistent-template-2.2:=[profile?]
+ dev-haskell/resource-pool:=[profile?]
+ >=dev-haskell/resourcet-0.4.5:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/yesod-core-1.4.0:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec
+ dev-haskell/persistent-sqlite
+ dev-haskell/text
+ dev-haskell/wai-extra )
+"
diff --git a/dev-haskell/yesod-persistent/yesod-persistent-1.4.0.3.ebuild b/dev-haskell/yesod-persistent/yesod-persistent-1.4.0.3.ebuild
new file mode 100644
index 000000000000..4cf3178a70c5
--- /dev/null
+++ b/dev-haskell/yesod-persistent/yesod-persistent-1.4.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Some helpers for using Persistent from Yesod"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.3:=[profile?]
+ >=dev-haskell/persistent-template-2.1:=[profile?] <dev-haskell/persistent-template-2.2:=[profile?]
+ dev-haskell/resource-pool:=[profile?]
+ >=dev-haskell/resourcet-0.4.5:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/yesod-core-1.4.0:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec
+ dev-haskell/persistent-sqlite
+ dev-haskell/text
+ dev-haskell/wai-extra )
+"