summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hashtables/files/hashtables-1.3.1-clang-argument-must-be-a-constant-integer.patch12
-rw-r--r--dev-haskell/hashtables/hashtables-1.3.1.ebuild6
2 files changed, 17 insertions, 1 deletions
diff --git a/dev-haskell/hashtables/files/hashtables-1.3.1-clang-argument-must-be-a-constant-integer.patch b/dev-haskell/hashtables/files/hashtables-1.3.1-clang-argument-must-be-a-constant-integer.patch
new file mode 100644
index 000000000000..a8dd7bcd9a87
--- /dev/null
+++ b/dev-haskell/hashtables/files/hashtables-1.3.1-clang-argument-must-be-a-constant-integer.patch
@@ -0,0 +1,12 @@
+--- hashtables-1.3.1-orig/cbits/sse-42.c 2001-09-09 11:46:40.000000000 +1000
++++ hashtables-1.3.1/cbits/sse-42.c 2024-06-01 12:50:27.039285052 +1000
+@@ -49,8 +49,7 @@
+ #define _MODE (SIDD_UWORD_OPS | SIDD_CMP_EQUAL_EACH)
+
+ static inline __m128i cmp_mask(__m128i a, __m128i b) {
+- const int mode = SIDD_UWORD_OPS | SIDD_CMP_EQUAL_EACH | SIDD_BIT_MASK;
+- return _mm_cmpistrm(a, b, mode);
++ return _mm_cmpistrm(a, b, SIDD_UWORD_OPS | SIDD_CMP_EQUAL_EACH | SIDD_BIT_MASK);
+ }
+
+ static inline int32_t line_result(uint32_t m, int start) {
diff --git a/dev-haskell/hashtables/hashtables-1.3.1.ebuild b/dev-haskell/hashtables/hashtables-1.3.1.ebuild
index 13d8df830c14..34972a4fa001 100644
--- a/dev-haskell/hashtables/hashtables-1.3.1.ebuild
+++ b/dev-haskell/hashtables/hashtables-1.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,6 +36,10 @@ DEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.1-clang-argument-must-be-a-constant-integer.patch
+)
+
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bounds-checking bounds-checking) \