summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hashed-storage/files/hashed-storage-0.5.11-QC-2.8.2.patch16
-rw-r--r--dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild1
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-QC-2.8.2.patch b/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-QC-2.8.2.patch
new file mode 100644
index 000000000000..1a001e73f537
--- /dev/null
+++ b/dev-haskell/hashed-storage/files/hashed-storage-0.5.11-QC-2.8.2.patch
@@ -0,0 +1,16 @@
+diff --git a/Storage/Hashed/Test.hs b/Storage/Hashed/Test.hs
+index d3cab6f..7f8291e 100644
+--- a/Storage/Hashed/Test.hs
++++ b/Storage/Hashed/Test.hs
+@@ -1,2 +1,2 @@
+-{-# LANGUAGE ScopedTypeVariables, FlexibleInstances #-}
++{-# LANGUAGE ScopedTypeVariables, FlexibleInstances, CPP #-}
+ module Storage.Hashed.Test( tests ) where
+@@ -464,2 +464,3 @@ posix = [ testCase "getFileStatus" $ check_stat Posix.getFileStatus
+
++#if ! MIN_VERSION_QuickCheck(2,8,2)
+ instance (Arbitrary a, Ord a) => Arbitrary (S.Set a)
+@@ -469,2 +470,3 @@ instance (Arbitrary k, Arbitrary v, Ord k) => Arbitrary (M.Map k v)
+ where arbitrary = M.fromList `fmap` arbitrary
++#endif
+
diff --git a/dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild b/dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild
index 094a567119a2..fb72b5ea9692 100644
--- a/dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild
+++ b/dev-haskell/hashed-storage/hashed-storage-0.5.11.ebuild
@@ -39,6 +39,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+ epatch "${FILESDIR}"/${P}-QC-2.8.2.patch
}
src_configure() {