summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/testpack/files/testpack-2.1.3.0-QC-2.8.2.patch12
-rw-r--r--dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild1
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-haskell/testpack/files/testpack-2.1.3.0-QC-2.8.2.patch b/dev-haskell/testpack/files/testpack-2.1.3.0-QC-2.8.2.patch
new file mode 100644
index 000000000000..9ea5f8dfe4d5
--- /dev/null
+++ b/dev-haskell/testpack/files/testpack-2.1.3.0-QC-2.8.2.patch
@@ -0,0 +1,12 @@
+diff --git a/src/Test/QuickCheck/Instances.hs b/src/Test/QuickCheck/Instances.hs
+index 98367b7..f65eb37 100644
+--- a/src/Test/QuickCheck/Instances.hs
++++ b/src/Test/QuickCheck/Instances.hs
+@@ -30,2 +30,3 @@ import Data.Word
+
++#if ! MIN_VERSION_QuickCheck(2,8,2)
+ instance (Arbitrary k, Arbitrary v, Eq k, Ord k) => Arbitrary (Map.Map k v) where
+@@ -37,2 +38,3 @@ instance (CoArbitrary k, CoArbitrary v, Eq k, Ord k) => CoArbitrary (Map.Map k v
+ coarbitrary = coarbitrary . Map.keys
++#endif
+
diff --git a/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild b/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
index 7168eb3b0ecf..d5f79b55c417 100644
--- a/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
+++ b/dev-haskell/testpack/testpack-2.1.3.0-r1.ebuild
@@ -31,4 +31,5 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-qc28.patch
epatch "${FILESDIR}"/${P}-HUnit-1.3.patch
+ epatch "${FILESDIR}"/${P}-QC-2.8.2.patch
}