summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild')
-rw-r--r--dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild b/dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild
new file mode 100644
index 000000000000..28f74af2d721
--- /dev/null
+++ b/dev-java/jackson-annotations/jackson-annotations-2.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="High-performance JSON processor"
+HOMEPAGE="https://github.com/FasterXML/jackson-annotations"
+SRC_URI="https://github.com/FasterXML/${PN}/archive/${PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${P}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../README.md ../release-notes/VERSION
+}