summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jffi/files')
-rw-r--r--dev-java/jffi/files/1.0.0-gcc-3.4.patch14
-rw-r--r--dev-java/jffi/files/jffi-1.0.0-makefile.patch82
-rw-r--r--dev-java/jffi/files/jffi-1.0.11_no-werror.patch13
-rw-r--r--dev-java/jffi/files/jffi-1.2.5_no-werror.patch13
-rw-r--r--dev-java/jffi/files/jffi-1.2.6_no-werror.patch13
-rw-r--r--dev-java/jffi/files/jffi-1.2.7-junit-4.11.patch14
-rw-r--r--dev-java/jffi/files/jffi-1.2.7-makefile.patch62
-rw-r--r--dev-java/jffi/files/jffi-1.2.7_no-werror.patch31
-rw-r--r--dev-java/jffi/files/jffi-1.2.8-junit-4.11.patch14
-rw-r--r--dev-java/jffi/files/jffi-1.2.8-makefile.patch52
-rw-r--r--dev-java/jffi/files/jffi_maven-build.xml259
11 files changed, 567 insertions, 0 deletions
diff --git a/dev-java/jffi/files/1.0.0-gcc-3.4.patch b/dev-java/jffi/files/1.0.0-gcc-3.4.patch
new file mode 100644
index 000000000000..fc2bd5cae10a
--- /dev/null
+++ b/dev-java/jffi/files/1.0.0-gcc-3.4.patch
@@ -0,0 +1,14 @@
+diff --git a/jni/GNUmakefile b/jni/GNUmakefile
+index 7a027af..eaba319 100755
+--- a/jni/GNUmakefile
++++ b/jni/GNUmakefile
+@@ -188,9 +188,6 @@ endif
+
+ ifeq ($(CPU), i386)
+ MODEL = 32
+- ifeq ($(findstring $(OS), openbsd darwin mingw32 win32),)
+- CFLAGS += -march=i586 -mtune=generic
+- endif
+ endif
+
+ ifeq ($(CPU), amd64)
diff --git a/dev-java/jffi/files/jffi-1.0.0-makefile.patch b/dev-java/jffi/files/jffi-1.0.0-makefile.patch
new file mode 100644
index 000000000000..11ca2ed68530
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.0.0-makefile.patch
@@ -0,0 +1,82 @@
+--- jni/GNUmakefile 2010-03-12 12:06:39.000000000 +1300
++++ jni/GNUmakefile 2010-03-12 12:13:44.000000000 +1300
+@@ -65,7 +65,7 @@
+
+ # MacOS headers aren't completely warning free, so turn them off
+ ifneq ($(OS),darwin)
+- WFLAGS = -W -Werror -Wall -Wno-unused -Wno-parentheses -Wundef
++ WFLAGS = -W -Wall -Wno-unused -Wno-parentheses -Wundef
+ endif
+ PICFLAGS = -fPIC
+ SOFLAGS = # Filled in for each OS specifically
+@@ -78,9 +78,9 @@
+
+ JDK_INCLUDES = -I"$(JDK_HOME)/include" -I"$(JDK_HOME)/include/$(OS)"
+ IFLAGS = -I"$(BUILD_DIR)" -I"$(BUILD_DIR)"/jni -I$(SRC_DIR) -I"$(JFFI_SRC_DIR)"
+-CFLAGS = $(OFLAGS) $(WFLAGS) $(IFLAGS) $(PICFLAGS) $(JDK_INCLUDES) $(LIBFFI_CFLAGS)
++CFLAGS += $(OFLAGS) $(WFLAGS) $(IFLAGS) $(PICFLAGS) $(JDK_INCLUDES) $(LIBFFI_CFLAGS)
+ CFLAGS += -D_REENTRANT -D_LARGEFILE64_SOURCE -D_GNU_SOURCE
+-CXXFLAGS = $(OFLAGS) $(IFLAGS) $(PICFLAGS) $(JDK_INCLUDES) $(LIBFFI_CFLAGS)
++CXXFLAGS += $(OFLAGS) $(IFLAGS) $(PICFLAGS) $(JDK_INCLUDES) $(LIBFFI_CFLAGS)
+
+ ifeq ($(OS), win64)
+ override CPU = x86_64
+@@ -258,58 +258,6 @@
+ @mkdir -p $(@D)
+ $(CCACHE) $(CXX) $(CXXFLAGS) -c $< -o $@
+
+-
+-ifeq ($(OS), darwin)
+-build_ffi = \
+- mkdir -p $(BUILD_DIR)/libffi-darwin-$(1); \
+- (if [ ! -f $(BUILD_DIR)/libffi-darwin-$(1)/Makefile ]; then \
+- echo "Configuring libffi for $(1)"; \
+- cd $(BUILD_DIR)/libffi-darwin-$(1) && \
+- env CC="$(CCACHE) $(CC)" CFLAGS="-arch $(1) $(FFI_CFLAGS)" LDFLAGS="-arch $(1)" \
+- $(LIBFFI_CONFIGURE) --host=$(1)-apple-darwin > /dev/null; \
+- fi); \
+- env MACOSX_DEPLOYMENT_TARGET=10.5 $(MAKE) -C $(BUILD_DIR)/libffi-darwin-$(1)
+-
+-$(LIBFFI):
+- @mkdir -p $(@D)
+- @for arch in $(ARCHES); do $(call build_ffi,$$arch);done
+-
+- # Assemble into a FAT (i386, x86_64, ppc) library
+- @mkdir -p $(BUILD_DIR)/libffi/.libs
+- @env MACOSX_DEPLOYMENT_TARGET=10.5 /usr/bin/libtool -static -o $@ \
+- $(foreach arch, $(ARCHES),$(BUILD_DIR)/libffi-darwin-$(arch)/.libs/libffi_convenience.a)
+- @mkdir -p $(LIBFFI_BUILD_DIR)/include
+- $(RM) $(LIBFFI_BUILD_DIR)/include/ffi.h
+- @( \
+- printf "#if defined(__i386__)\n"; \
+- printf "#include \"libffi-darwin-i386/include/ffi.h\"\n"; \
+- printf "#elif defined(__x86_64__)\n"; \
+- printf "#include \"libffi-darwin-x86_64/include/ffi.h\"\n";\
+- printf "#elif defined(__ppc__)\n"; \
+- printf "#include \"libffi-darwin-ppc/include/ffi.h\"\n";\
+- printf "#endif\n";\
+- ) > $(LIBFFI_BUILD_DIR)/include/ffi.h
+- @( \
+- printf "#if defined(__i386__)\n"; \
+- printf "#include \"libffi-darwin-i386/include/ffitarget.h\"\n"; \
+- printf "#elif defined(__x86_64__)\n"; \
+- printf "#include \"libffi-darwin-x86_64/include/ffitarget.h\"\n";\
+- printf "#elif defined(__ppc__)\n"; \
+- printf "#include \"libffi-darwin-ppc/include/ffitarget.h\"\n";\
+- printf "#endif\n";\
+- ) > $(LIBFFI_BUILD_DIR)/include/ffitarget.h
+-else
+-$(LIBFFI):
+- @mkdir -p $(LIBFFI_BUILD_DIR)
+- @if [ ! -f $(LIBFFI_BUILD_DIR)/Makefile ]; then \
+- echo "Configuring libffi for $(PLATFORM)"; \
+- cd $(LIBFFI_BUILD_DIR) && env CC="$(FFI_CC)" LD="$(FFI_LD)" CFLAGS="$(FFI_CFLAGS)" \
+- $(LIBFFI_CONFIGURE) > /dev/null; \
+- fi
+- $(MAKE) -C $(LIBFFI_BUILD_DIR)
+-endif
+-
+-
+ clean::
+ # nothing to do - ant will delete the build dir
+
diff --git a/dev-java/jffi/files/jffi-1.0.11_no-werror.patch b/dev-java/jffi/files/jffi-1.0.11_no-werror.patch
new file mode 100644
index 000000000000..25b7e4f8ec00
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.0.11_no-werror.patch
@@ -0,0 +1,13 @@
+diff --git a/jni/GNUmakefile b/jni/GNUmakefile
+index efe6230..25053c7 100755
+--- a/jni/GNUmakefile
++++ b/jni/GNUmakefile
+@@ -64,7 +64,7 @@ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing -DNDEBUG
+ OFLAGS = -O2 $(JFLAGS)
+
+ # MacOS headers aren't completely warning free, so turn them off
+-WERROR = -Werror
++WERROR =
+ ifneq ($(OS),darwin)
+ WFLAGS += -Wundef $(WERROR)
+ endif
diff --git a/dev-java/jffi/files/jffi-1.2.5_no-werror.patch b/dev-java/jffi/files/jffi-1.2.5_no-werror.patch
new file mode 100644
index 000000000000..25b7e4f8ec00
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.2.5_no-werror.patch
@@ -0,0 +1,13 @@
+diff --git a/jni/GNUmakefile b/jni/GNUmakefile
+index efe6230..25053c7 100755
+--- a/jni/GNUmakefile
++++ b/jni/GNUmakefile
+@@ -64,7 +64,7 @@ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing -DNDEBUG
+ OFLAGS = -O2 $(JFLAGS)
+
+ # MacOS headers aren't completely warning free, so turn them off
+-WERROR = -Werror
++WERROR =
+ ifneq ($(OS),darwin)
+ WFLAGS += -Wundef $(WERROR)
+ endif
diff --git a/dev-java/jffi/files/jffi-1.2.6_no-werror.patch b/dev-java/jffi/files/jffi-1.2.6_no-werror.patch
new file mode 100644
index 000000000000..25b7e4f8ec00
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.2.6_no-werror.patch
@@ -0,0 +1,13 @@
+diff --git a/jni/GNUmakefile b/jni/GNUmakefile
+index efe6230..25053c7 100755
+--- a/jni/GNUmakefile
++++ b/jni/GNUmakefile
+@@ -64,7 +64,7 @@ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing -DNDEBUG
+ OFLAGS = -O2 $(JFLAGS)
+
+ # MacOS headers aren't completely warning free, so turn them off
+-WERROR = -Werror
++WERROR =
+ ifneq ($(OS),darwin)
+ WFLAGS += -Wundef $(WERROR)
+ endif
diff --git a/dev-java/jffi/files/jffi-1.2.7-junit-4.11.patch b/dev-java/jffi/files/jffi-1.2.7-junit-4.11.patch
new file mode 100644
index 000000000000..ac3843a0053a
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.2.7-junit-4.11.patch
@@ -0,0 +1,14 @@
+--- a/src/test/java/com/kenai/jffi/NumberTest.java
++++ b/src/test/java/com/kenai/jffi/NumberTest.java
+@@ -234,9 +234,8 @@
+ private void returnF32(InvokerType type) {
+ LibNumberTest lib = UnitHelper.loadTestLibrary(LibNumberTest.class, type);
+ float[] values = { 0f, 1.0f, -2.0f };
+- for (int i = 0; i < values.length; ++i) {
+- assertEquals("Value not returned correctly", values[i], lib.ret_float(values[i]), 0.1f);
+- }
++ float[] lib_values = { lib.ret_float(0f), lib.ret_float(1.0f), lib.ret_float(-2.0f) };
++ assertArrayEquals("Value not returned correctly", values, lib_values, 0.1f);
+ }
+
+ @Test public void returnDefaultF64() {
diff --git a/dev-java/jffi/files/jffi-1.2.7-makefile.patch b/dev-java/jffi/files/jffi-1.2.7-makefile.patch
new file mode 100644
index 000000000000..ed17f7882ce5
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.2.7-makefile.patch
@@ -0,0 +1,62 @@
+diff --git a/jffi-1.2.7/jni/GNUmakefile b/jffi-1.2.7/jni/GNUmakefile
+index 27737be..2e709d9 100755
+--- a/jffi-1.2.7/jni/GNUmakefile
++++ b/jffi-1.2.7/jni/GNUmakefile
+@@ -47,7 +47,6 @@ else
+ LIBFFI_SRC_DIR = $(SRC_DIR)/libffi
+ LIBFFI_BUILD_DIR = $(BUILD_DIR)/libffi-$(PLATFORM)
+ LIBFFI = $(LIBFFI_BUILD_DIR)/.libs/libffi_convenience.a
+- LIBFFI_LIBS = $(LIBFFI)
+ LIBFFI_CFLAGS = -I"$(LIBFFI_BUILD_DIR)"/include
+ endif
+
+@@ -64,11 +63,11 @@ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing -DNDEBUG
+ OFLAGS = -O2 $(JFLAGS)
+
+ # MacOS headers aren't completely warning free, so turn them off
+-WERROR = -Werror
++WERROR =
+ ifneq ($(OS),darwin)
+ WFLAGS += -Wundef $(WERROR)
+ endif
+-WFLAGS += -W -Wall -Wno-unused -Wno-parentheses
++WFLAGS += -W -Wall -Wno-unused -Wno-unused-parameter -Wno-parentheses
+ PICFLAGS = -fPIC
+ SOFLAGS = # Filled in for each OS specifically
+ FFI_MMAP_EXEC = -DFFI_MMAP_EXEC_WRIT
+@@ -279,7 +278,7 @@ debug:
+ @echo "JFFI_BUILD_DIR=$(JFFI_BUILD_DIR)"
+ @echo "OBJS=$(OBJS)"
+
+-$(LIBJFFI): $(OBJS) $(LIBFFI_LIBS)
++$(LIBJFFI): $(OBJS)
+ $(CC) -o $@ $(LDFLAGS) $(SOFLAGS) $(OBJS) $(LIBFFI_LIBS) $(LIBS)
+ $(STRIP) $@
+
+@@ -291,7 +290,7 @@ $(BUILD_DIR)/%.o : $(SRC_DIR)/%.S $(wildcard $(JFFI_SRC_DIR)/*.h)
+ @mkdir -p $(@D)
+ @$(CC) $(CFLAGS) -o $@ -c $<
+
+-$(OBJS) : $(LIBFFI_LIBS)
++$(OBJS) :
+
+ ifeq ($(OS), darwin)
+ build_ffi = \
+diff --git a/jffi-1.2.7/libtest/GNUmakefile b/jffi-1.2.7/libtest/GNUmakefile
+index 9e70664..3e279a3 100644
+--- a/jffi-1.2.7/libtest/GNUmakefile
++++ b/jffi-1.2.7/libtest/GNUmakefile
+@@ -44,10 +44,10 @@ TEST_OBJS := $(patsubst $(SRC_DIR)/%.c, $(TEST_BUILD_DIR)/%.o, $(TEST_SRCS))
+ # Compiler/linker flags from:
+ # http://weblogs.java.net/blog/kellyohair/archive/2006/01/compilation_of_1.html
+ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing
+-OFLAGS = -O2 $(JFLAGS)
+-WFLAGS = -W -Werror -Wall -Wno-unused -Wno-parentheses
++OFLAGS = $(JFLAGS)
++WFLAGS = -W -Wall -Wno-unused -Wno-unused-parameter -Wno-parentheses
+ PICFLAGS = -fPIC
+-SOFLAGS = -shared -Wl,-O1
++SOFLAGS = -shared
+ LDFLAGS += $(SOFLAGS)
+
+ IFLAGS = -I"$(BUILD_DIR)"
diff --git a/dev-java/jffi/files/jffi-1.2.7_no-werror.patch b/dev-java/jffi/files/jffi-1.2.7_no-werror.patch
new file mode 100644
index 000000000000..517a1e546d8b
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.2.7_no-werror.patch
@@ -0,0 +1,31 @@
+diff --git a/jffi-1.2.7/jni/GNUmakefile b/jffi-1.2.7/jni/GNUmakefile
+index 27737be..98f147e 100755
+--- a/jffi-1.2.7/jni/GNUmakefile
++++ b/jffi-1.2.7/jni/GNUmakefile
+@@ -64,7 +64,7 @@ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing -DNDEBUG
+ OFLAGS = -O2 $(JFLAGS)
+
+ # MacOS headers aren't completely warning free, so turn them off
+-WERROR = -Werror
++WERROR =
+ ifneq ($(OS),darwin)
+ WFLAGS += -Wundef $(WERROR)
+ endif
+diff --git a/jffi-1.2.7/libtest/GNUmakefile b/jffi-1.2.7/libtest/GNUmakefile
+index 9e70664..72e4cc9 100644
+--- a/jffi-1.2.7/libtest/GNUmakefile
++++ b/jffi-1.2.7/libtest/GNUmakefile
+@@ -44,10 +44,10 @@ TEST_OBJS := $(patsubst $(SRC_DIR)/%.c, $(TEST_BUILD_DIR)/%.o, $(TEST_SRCS))
+ # Compiler/linker flags from:
+ # http://weblogs.java.net/blog/kellyohair/archive/2006/01/compilation_of_1.html
+ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing
+-OFLAGS = -O2 $(JFLAGS)
+-WFLAGS = -W -Werror -Wall -Wno-unused -Wno-parentheses
++OFLAGS = $(JFLAGS)
++WFLAGS = -W -Wall -Wno-unused -Wno-parentheses
+ PICFLAGS = -fPIC
+-SOFLAGS = -shared -Wl,-O1
++SOFLAGS = -shared
+ LDFLAGS += $(SOFLAGS)
+
+ IFLAGS = -I"$(BUILD_DIR)"
diff --git a/dev-java/jffi/files/jffi-1.2.8-junit-4.11.patch b/dev-java/jffi/files/jffi-1.2.8-junit-4.11.patch
new file mode 100644
index 000000000000..ac3843a0053a
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.2.8-junit-4.11.patch
@@ -0,0 +1,14 @@
+--- a/src/test/java/com/kenai/jffi/NumberTest.java
++++ b/src/test/java/com/kenai/jffi/NumberTest.java
+@@ -234,9 +234,8 @@
+ private void returnF32(InvokerType type) {
+ LibNumberTest lib = UnitHelper.loadTestLibrary(LibNumberTest.class, type);
+ float[] values = { 0f, 1.0f, -2.0f };
+- for (int i = 0; i < values.length; ++i) {
+- assertEquals("Value not returned correctly", values[i], lib.ret_float(values[i]), 0.1f);
+- }
++ float[] lib_values = { lib.ret_float(0f), lib.ret_float(1.0f), lib.ret_float(-2.0f) };
++ assertArrayEquals("Value not returned correctly", values, lib_values, 0.1f);
+ }
+
+ @Test public void returnDefaultF64() {
diff --git a/dev-java/jffi/files/jffi-1.2.8-makefile.patch b/dev-java/jffi/files/jffi-1.2.8-makefile.patch
new file mode 100644
index 000000000000..7f9f07a500c5
--- /dev/null
+++ b/dev-java/jffi/files/jffi-1.2.8-makefile.patch
@@ -0,0 +1,52 @@
+--- jni/GNUmakefile
++++ jni/GNUmakefile
+@@ -41,6 +41,7 @@
+ JFFI_BUILD_DIR = $(BUILD_DIR)/jffi
+
+ ifeq ($(USE_SYSTEM_LIBFFI),1)
++ LIBFFI =
+ LIBFFI_LIBS ?= $(shell pkg-config --libs libffi)
+ LIBFFI_CFLAGS ?= $(shell pkg-config --cflags libffi)
+ else
+@@ -64,9 +65,8 @@
+ OFLAGS = -O2 $(JFLAGS)
+
+ # MacOS headers aren't completely warning free, so turn them off
+-WERROR = -Werror
+ ifneq ($(OS),darwin)
+- WFLAGS += -Wundef $(WERROR)
++ WFLAGS += -Wundef
+ endif
+ WFLAGS += -W -Wall -Wno-unused -Wno-parentheses -Wno-unused-parameter
+ PICFLAGS = -fPIC
+@@ -279,7 +279,7 @@
+ @echo "JFFI_BUILD_DIR=$(JFFI_BUILD_DIR)"
+ @echo "OBJS=$(OBJS)"
+
+-$(LIBJFFI): $(OBJS) $(LIBFFI_LIBS)
++$(LIBJFFI): $(OBJS) $(LIBFFI)
+ $(CC) -o $@ $(LDFLAGS) $(SOFLAGS) $(OBJS) $(LIBFFI_LIBS) $(LIBS)
+ $(STRIP) $@
+
+@@ -291,7 +291,7 @@
+ @mkdir -p $(@D)
+ @$(CC) $(CFLAGS) -o $@ -c $<
+
+-$(OBJS) : $(LIBFFI_LIBS)
++$(OBJS) : $(LIBFFI)
+
+ ifeq ($(OS), darwin)
+ build_ffi = \
+--- libtest/GNUmakefile
++++ libtest/GNUmakefile
+@@ -44,8 +44,8 @@
+ # Compiler/linker flags from:
+ # http://weblogs.java.net/blog/kellyohair/archive/2006/01/compilation_of_1.html
+ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing
+-OFLAGS = -O2 $(JFLAGS)
+-WFLAGS = -W -Werror -Wall -Wno-unused -Wno-unused-parameter -Wno-parentheses
++OFLAGS = $(JFLAGS)
++WFLAGS = -W -Wall -Wno-unused -Wno-unused-parameter -Wno-parentheses
+ PICFLAGS = -fPIC
+ SOFLAGS = -shared -Wl,-O1
+ LDFLAGS += $(SOFLAGS)
diff --git a/dev-java/jffi/files/jffi_maven-build.xml b/dev-java/jffi/files/jffi_maven-build.xml
new file mode 100644
index 000000000000..d8114185ee41
--- /dev/null
+++ b/dev-java/jffi/files/jffi_maven-build.xml
@@ -0,0 +1,259 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 1/9/12 9:52 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jffi-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jffi-1.0.11"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.1"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.1"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.8.2"/>
+ <get src="http://repository.jboss.com/maven2/junit/junit/4.8.2/junit-4.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://snapshots.jboss.org/maven2/junit/junit/4.8.2/junit-4.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repository.jboss.org/maven2//junit/junit/4.8.2/junit-4.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://repository.jboss.org/nexus/content/groups/public-jboss//junit/junit/4.8.2/junit-4.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/junit/junit/4.8.2/junit-4.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo1.maven.org/maven2/junit/junit/4.8.2/junit-4.8.2.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.2/junit-4.8.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>