summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/openjdk-bin/openjdk-bin-11.0.3_p7.ebuild')
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-11.0.3_p7.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-java/openjdk-bin/openjdk-bin-11.0.3_p7.ebuild b/dev-java/openjdk-bin/openjdk-bin-11.0.3_p7.ebuild
index ad6e3e5d68c6..aa4a0aeb2e88 100644
--- a/dev-java/openjdk-bin/openjdk-bin-11.0.3_p7.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-11.0.3_p7.ebuild
@@ -53,7 +53,7 @@ S="${WORKDIR}/jdk-${MY_PV}"
src_install() {
local dest="/opt/${P}"
- local ddest="${ED}${dest#/}"
+ local ddest="${ED%/}/${dest#/}"
# Not sure why they bundle this as it's commonly available and they
# only do so on x86_64. It's needed by libfontmanager.so. IcedTea
@@ -78,9 +78,13 @@ src_install() {
rm -v lib/src.zip || die
fi
+ mv lib/security/cacerts lib/security/cacerts.orig || die
+
dodir "${dest}"
cp -pPR * "${ddest}" || die
+ dosym "${EPREFIX}"/etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+
use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask