summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/xz-java')
-rw-r--r--dev-java/xz-java/xz-java-1.6-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/xz-java/xz-java-1.6-r1.ebuild b/dev-java/xz-java/xz-java-1.6-r1.ebuild
new file mode 100644
index 000000000000..04141c97d6c6
--- /dev/null
+++ b/dev-java/xz-java/xz-java-1.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Implementation of xz data compression in pure java"
+HOMEPAGE="http://tukaani.org/xz/java.html"
+SRC_URI="http://tukaani.org/xz/${P}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6"
+
+S="${WORKDIR}"
+
+JAVA_SRC_DIR="src/org"
+
+DOCS=( README NEWS COPYING THANKS )
+
+src_install() {
+ java-pkg-simple_src_install
+ use examples && java-pkg_doexamples src/*Demo.java
+ einstalldocs
+}