summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gnat-gpl')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2016.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2016.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2016.ebuild
index 77ac3e15dcd7..2709a1c0990b 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2016.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2016.ebuild
@@ -57,10 +57,14 @@ GCC_A_FAKEIT="${P}-src.tar.gz
pkg_setup() {
GCC=${ADA:-$(tc-getCC)}
- local path=$(dirname ${GCC})
local base=$(basename ${GCC})
- GNATMAKE="${path}/${base/gcc/gnatmake}"
- GNATBIND="${path}/${base/gcc/gnatbind}"
+ GNATMAKE="${base/gcc/gnatmake}"
+ GNATBIND="${base/gcc/gnatbind}"
+ if [[ ${base} != ${GCC} ]] ; then
+ local path=$(dirname ${GCC})
+ GNATMAKE="${path}/${GNATMAKE}"
+ GNATBIND="${path}/${GNATBIND}"
+ fi
if [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
eerror "You need a gcc compiler that provides the Ada Compiler:"
eerror "1) use gcc-config to select the right compiler or"