summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/hy/hy-0.10.1.ebuild')
-rw-r--r--dev-lang/hy/hy-0.10.1.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-lang/hy/hy-0.10.1.ebuild b/dev-lang/hy/hy-0.10.1.ebuild
deleted file mode 100644
index 860d13e0951a..000000000000
--- a/dev-lang/hy/hy-0.10.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-RESTRICT="test" # needs some pointy sticks. Seriously.
-PYTHON_COMPAT=(python2_7)
-
-inherit distutils-r1
-DESCRIPTION="A LISP dialect running in python"
-HOMEPAGE="http://hylang.org/"
-SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
- >=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
- dev-python/astor[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/tox[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}