summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/perl/perl-5.24.1_rc4.ebuild')
-rw-r--r--dev-lang/perl/perl-5.24.1_rc4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/perl/perl-5.24.1_rc4.ebuild b/dev-lang/perl/perl-5.24.1_rc4.ebuild
index e560ac1a57b1..47bd73ddc2a5 100644
--- a/dev-lang/perl/perl-5.24.1_rc4.ebuild
+++ b/dev-lang/perl/perl-5.24.1_rc4.ebuild
@@ -215,6 +215,7 @@ src_prepare_update_patchlevel_h() {
# it under the same terms as Perl itself.
local patchdir="${WORKDIR}/patches"
local prefix
+ local patchoutput="patchlevel-gentoo.h"
[[ -f ${patchdir}/series ]] || return 0
@@ -252,9 +253,8 @@ do
# label: prepend to the hold space
:prepend x; H; d;
'
-done < "${WORKDIR}"/patches/series > "${S}/patchlevel-gentoo.h"
-
- eapply "${FILESDIR}/perl-patchlevel-manifest.patch"
+done < "${WORKDIR}"/patches/series > "${S}/${patchoutput}"
+echo "${patchoutput}" >> "${S}/MANIFEST"
}
src_prepare() {