summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python-exec/python-exec-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-lang/python-exec/python-exec-9999.ebuild b/dev-lang/python-exec/python-exec-9999.ebuild
index 2b77cc79e78a..b835c894838d 100644
--- a/dev-lang/python-exec/python-exec-9999.ebuild
+++ b/dev-lang/python-exec/python-exec-9999.ebuild
@@ -68,11 +68,17 @@ src_install() {
insinto /etc/python-exec
doins "${T}"/python-exec.conf
- # Create Python interpreter executable wrappers
local f
- for f in python{,2,3}{,-config} 2to3 idle pydoc pyvenv; do
+ for f in python{,2,3}; do
+ # symlink the C wrapper for python to avoid shebang recursion
+ # bug #568974
dosym python-exec2c /usr/bin/"${f}"
done
+ for f in python{,2,3}-config 2to3 idle pydoc pyvenv; do
+ # those are python scripts (except for new python-configs)
+ # so symlink them via the python wrapper
+ dosym ../lib/python-exec/python-exec2 /usr/bin/"${f}"
+ done
}
pkg_preinst() {