summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gdl')
-rw-r--r--dev-libs/gdl/Manifest2
-rw-r--r--dev-libs/gdl/gdl-3.14.0.ebuild33
-rw-r--r--dev-libs/gdl/gdl-3.16.0.ebuild33
-rw-r--r--dev-libs/gdl/metadata.xml5
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-libs/gdl/Manifest b/dev-libs/gdl/Manifest
new file mode 100644
index 000000000000..82e0543782c2
--- /dev/null
+++ b/dev-libs/gdl/Manifest
@@ -0,0 +1,2 @@
+DIST gdl-3.14.0.tar.xz 537916 SHA256 4b903c28a8894a82b997a1732a443c8b1d6a510304b3c3b511023339ff5d01db SHA512 f602350e699ff539cb6f6523566653ce50d19b02a5490a4489bf94ef3e7904a64b97f2876745b42485266077bbe520383b765b45c9a2dfab5f42dff37c2323b5 WHIRLPOOL 6c8710c10cf866b3ea7653d2101e6c98cef22301206bc3b73ee91618d57c3e8e12c91e77c6e55d5b2f65124c8ad4ba33c94d1a51e6b3b648713870a30eae8537
+DIST gdl-3.16.0.tar.xz 527328 SHA256 34cbe104f5df9a20ea26aa8acca2b6d1a73035448aa854162c598e90f4e6ff80 SHA512 77a54a7ae1603f942e7f0731c76907a8e1f4fd1d20e27e13c365fd2f6130e2331ca3d467dccea032a5ac0303035df58271849f2f4e32df8f037868fd24351a94 WHIRLPOOL ca51eb143146b6bb380ee76ce3cfc7b7e4b1bff317d49045ec00e8f994034d947f1b2cae2590f9e891b88d57bac78ad08042f6d5bceb34f2f7c30e1572873dd0
diff --git a/dev-libs/gdl/gdl-3.14.0.ebuild b/dev-libs/gdl/gdl-3.14.0.ebuild
new file mode 100644
index 000000000000..ba5401e7eddb
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.14.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://developer.gnome.org/gdl/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure $(use_enable introspection)
+}
diff --git a/dev-libs/gdl/gdl-3.16.0.ebuild b/dev-libs/gdl/gdl-3.16.0.ebuild
new file mode 100644
index 000000000000..a50bb72d9341
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.16.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://developer.gnome.org/gdl/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure $(use_enable introspection)
+}
diff --git a/dev-libs/gdl/metadata.xml b/dev-libs/gdl/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/dev-libs/gdl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>