summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ivykis/ivykis-0.42.3-r1.ebuild')
-rw-r--r--dev-libs/ivykis/ivykis-0.42.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/ivykis/ivykis-0.42.3-r1.ebuild b/dev-libs/ivykis/ivykis-0.42.3-r1.ebuild
new file mode 100644
index 000000000000..a5ee1b0d17d3
--- /dev/null
+++ b/dev-libs/ivykis/ivykis-0.42.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Library for asynchronous I/O readiness notification"
+HOMEPAGE="https://github.com/buytenh/ivykis"
+SRC_URI="https://github.com/buytenh/ivykis/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -delete || die
+}