summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgit2/libgit2-0.99.0.ebuild')
-rw-r--r--dev-libs/libgit2/libgit2-0.99.0.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-libs/libgit2/libgit2-0.99.0.ebuild b/dev-libs/libgit2/libgit2-0.99.0.ebuild
index 23bd171e3106..3abe4784a16c 100644
--- a/dev-libs/libgit2/libgit2-0.99.0.ebuild
+++ b/dev-libs/libgit2/libgit2-0.99.0.ebuild
@@ -6,19 +6,14 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
inherit cmake python-any-r1
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
-fi
-
DESCRIPTION="A linkable library for Git"
HOMEPAGE="https://libgit2.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${P/_/-}
LICENSE="GPL-2-with-linking-exception"
-SLOT="0/28"
+SLOT="0/0.99"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
IUSE="examples gssapi libressl +ssh test +threads trace"
RESTRICT="!test? ( test )"
@@ -35,7 +30,11 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
-S=${WORKDIR}/${P/_/-}
+src_prepare() {
+ cmake_src_prepare
+ # relying on forked http-parser to support some obscure URI form
+ sed -i -e '/empty_port/s:test:_&:' tests/network/urlparse.c || die
+}
src_configure() {
local mycmakeargs=(