summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libp11/libp11-0.4.10-r1.ebuild')
-rw-r--r--dev-libs/libp11/libp11-0.4.10-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libp11/libp11-0.4.10-r1.ebuild b/dev-libs/libp11/libp11-0.4.10-r1.ebuild
new file mode 100644
index 000000000000..b9fcd14e12ac
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.4.10-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
+HOMEPAGE="https://github.com/opensc/libp11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
+IUSE="bindist doc static-libs"
+
+RDEPEND="
+ dev-libs/openssl:0=[bindist(-)=]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}