summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libressl/libressl-2.4.3.ebuild')
-rw-r--r--dev-libs/libressl/libressl-2.4.3.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-libs/libressl/libressl-2.4.3.ebuild b/dev-libs/libressl/libressl-2.4.3.ebuild
deleted file mode 100644
index e6602882fd3a..000000000000
--- a/dev-libs/libressl/libressl-2.4.3.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib-minimal
-
-DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
-
-LICENSE="ISC openssl"
-# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
-# we'll try to use the max of either. However, if either change between
-# versions, we have to change the subslot to trigger rebuild of consumers.
-SLOT="0/39"
-KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
-IUSE="+asm static-libs"
-
-RDEPEND="!dev-libs/openssl:0"
-DEPEND="${RDEPEND}"
-PDEPEND="app-misc/ca-certificates"
-
-src_prepare() {
- touch crypto/Makefile.in
-
- sed -i \
- -e '/^[ \t]*CFLAGS=/s#-g ##' \
- -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
- -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
- -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
- -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
- -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
- configure || die "fixing CFLAGS failed"
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable asm) \
- $(use_enable static-libs static)
-}
-
-multilib_src_test() {
- emake check
-}
-
-multilib_src_install_all() {
- einstalldocs
- prune_libtool_files
-}