summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libunicode')
-rw-r--r--dev-libs/libunicode/libunicode-0.4-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/libunicode/libunicode-0.4-r2.ebuild b/dev-libs/libunicode/libunicode-0.4-r2.ebuild
new file mode 100644
index 000000000000..88dcbf104bb1
--- /dev/null
+++ b/dev-libs/libunicode/libunicode-0.4-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Unicode library"
+HOMEPAGE="https://www.gnome.org/"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/${PN}/${PV}/${P}.gnome.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ default
+ # The build system is too old, regenerate here to fix crossbuild and
+ # respect LDFLAGS and probably other problems too.
+ sed -i -e "/testsuite/d" configure.in || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}