summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/weston/weston-9999.ebuild')
-rw-r--r--dev-libs/weston/weston-9999.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 308920a07a3d..31eafda37fea 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,7 +12,7 @@ fi
VIRTUALX_REQUIRED="test"
RESTRICT="test"
-inherit autotools readme.gentoo toolchain-funcs virtualx $GIT_ECLASS
+inherit autotools readme.gentoo-r1 toolchain-funcs virtualx $GIT_ECLASS
DESCRIPTION="Wayland reference compositor"
HOMEPAGE="http://wayland.freedesktop.org/"
@@ -27,7 +27,9 @@ fi
LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
-IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland"
+
+IUSE_VIDEO_CARDS="video_cards_intel video_cards_v4l"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland ${IUSE_VIDEO_CARDS}"
REQUIRED_USE="
drm? ( gles2 )
@@ -38,8 +40,9 @@ REQUIRED_USE="
RDEPEND="
>=dev-libs/libinput-0.8.0
- >=dev-libs/wayland-1.9.0
- media-libs/lcms:2
+ >=dev-libs/wayland-1.9.90
+ >=dev-libs/wayland-protocols-1.0
+ lcms? ( media-libs/lcms:2 )
media-libs/libpng:0=
media-libs/libwebp:0=
virtual/jpeg:0=
@@ -112,6 +115,7 @@ src_configure() {
$(use_enable drm drm-compositor) \
$(use_enable headless headless-compositor) \
$(use_enable ivi ivi-shell) \
+ $(use_enable lcms) \
$(use_enable rdp rdp-compositor) \
$(use_enable rpi rpi-compositor) \
$(use_enable wayland-compositor) \
@@ -125,6 +129,8 @@ src_configure() {
$(use_enable suid setuid-install) \
$(use_enable xwayland) \
$(use_enable xwayland xwayland-test) \
+ $(use_enable video_cards_intel simple-dmabuf-intel-client) \
+ $(use_enable video_cards_v4l simple-dmabuf-v4l-client) \
${myconf}
}
@@ -140,5 +146,5 @@ src_test() {
src_install() {
default
- readme.gentoo_src_install
+ readme.gentoo_create_doc
}