summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/biniou/biniou-1.0.9.ebuild')
-rw-r--r--dev-ml/biniou/biniou-1.0.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/biniou/biniou-1.0.9.ebuild b/dev-ml/biniou/biniou-1.0.9.ebuild
new file mode 100644
index 000000000000..b5bb8f13dae8
--- /dev/null
+++ b/dev-ml/biniou/biniou-1.0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A binary data serialization format inspired by JSON for OCaml"
+HOMEPAGE="http://mjambon.com/biniou.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -j1 all
+ use ocamlopt && emake -j1 opt
+}
+
+src_install() {
+ use ocamlopt && dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+}