summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/bos/bos-0.1.6.ebuild')
-rw-r--r--dev-ml/bos/bos-0.1.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/bos/bos-0.1.6.ebuild b/dev-ml/bos/bos-0.1.6.ebuild
new file mode 100644
index 000000000000..a3b7dc553e2e
--- /dev/null
+++ b/dev-ml/bos/bos-0.1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Basic OS interaction for OCaml"
+HOMEPAGE="http://erratique.ch/software/bos https://github.com/dbuenzli/bos"
+SRC_URI="http://erratique.ch/software/bos/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/rresult:=
+ dev-ml/astring:=
+ dev-ml/fpath:=
+ dev-ml/fmt:=
+ dev-ml/logs:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ test? ( dev-ml/mtime )
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}