summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/cppo/cppo-1.0.1.ebuild')
-rw-r--r--dev-ml/cppo/cppo-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/cppo/cppo-1.0.1.ebuild b/dev-ml/cppo/cppo-1.0.1.ebuild
new file mode 100644
index 000000000000..3d525ab5b351
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}