summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/deriving/deriving-0.7.ebuild')
-rw-r--r--dev-ml/deriving/deriving-0.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/deriving/deriving-0.7.ebuild b/dev-ml/deriving/deriving-0.7.ebuild
new file mode 100644
index 000000000000..7f8b26b12a67
--- /dev/null
+++ b/dev-ml/deriving/deriving-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A deriving library for Ocsigen"
+HOMEPAGE="http://github.com/ocsigen/deriving"
+SRC_URI="http://github.com/ocsigen/deriving/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/type-conv-108:=
+ dev-ml/optcomp:=
+ dev-ml/findlib:=
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/oasis"
+
+DOCS=( CHANGES README.md )
+oasis_configure_opts="--enable-tc"
+OASIS_SETUP_COMMAND="./setup.exe"
+
+src_configure() {
+ emake setup.exe
+ oasis_src_configure
+}