summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/flow_parser/flow_parser-0.44.0.ebuild')
-rw-r--r--dev-ml/flow_parser/flow_parser-0.44.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ml/flow_parser/flow_parser-0.44.0.ebuild b/dev-ml/flow_parser/flow_parser-0.44.0.ebuild
deleted file mode 100644
index 8460f51ef8ba..000000000000
--- a/dev-ml/flow_parser/flow_parser-0.44.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit findlib
-
-DESCRIPTION="JavaScript parser written in OCaml"
-HOMEPAGE="https://github.com/facebook/flow/tree/master/src/parser"
-SRC_URI="https://github.com/facebook/flow/archive/v${PV}.tar.gz -> flow-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-lang/ocaml:="
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- dev-ml/ocamlbuild"
-
-S="${WORKDIR}/flow-${PV}/src/parser"
-
-src_compile() {
- ocamlbuild parser_flow.cma parser_flow.cmxa || die
-}
-
-src_test() {
- emake test-ocaml
-}
-
-src_install() {
- findlib_src_preinst
- emake ocamlfind-install
- dodoc README.md
-}