summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/mongo/mongo-0.67.2.ebuild')
-rw-r--r--dev-ml/mongo/mongo-0.67.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/mongo/mongo-0.67.2.ebuild b/dev-ml/mongo/mongo-0.67.2.ebuild
new file mode 100644
index 000000000000..9c43349a1e86
--- /dev/null
+++ b/dev-ml/mongo/mongo-0.67.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="An ocaml driver for mongodb"
+HOMEPAGE="http://massd.github.io/"
+SRC_URI="https://github.com/MassD/mongo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/bson:=
+ dev-ml/lwt:=
+"
+DEPEND="${RDEPEND} dev-ml/oasis"
+
+src_prepare() {
+ epatch "${FILESDIR}/noinstalltest.patch"
+ oasis setup || die
+}