summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild')
-rw-r--r--dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild
new file mode 100644
index 000000000000..6402be1841e6
--- /dev/null
+++ b/dev-ml/ocaml-conduit/ocaml-conduit-0.15.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/sexplib:=
+ dev-ml/stringext:=
+ dev-ml/ocaml-uri:=
+ dev-ml/logs:=
+ dev-ml/ocaml-cstruct:=
+ dev-ml/ocaml-ipaddr:=
+
+ dev-ml/lwt:=
+ dev-ml/async:=
+ dev-ml/ocaml-dns:=
+ dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ppx_driver
+ dev-ml/ppx_optcomp
+ dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+ findlib_src_preinst
+ default
+}